How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Greg Your Own Question
Greg
Greg, import technician
Category: Nissan
Satisfied Customers: 6891
Experience:  import Technician . Shop Owner ,. 27 years experience,
29331485
Type Your Nissan Question Here...
Greg is online now
A new question is answered every 9 seconds

Had my barings fixed passenger side front and was fixed by

Customer Question

Had my barings fixed passenger side front and was fixed by Firestone. Now ABS and Slip lights are now on and*****will not engage. Took back to Firestone they said it was probably faulty baring and replaced again. Still did not fix the*****or ABS or Slip lights. Firestone told me to take to Nissan dealer and the closest one is an hour or more away.
JA: Is it just the ABS light? Or is the brake system warning light on, too?
Customer: Just ABS and Slip and 4x4 flashes when turning to 4 high but will not engage.
JA: What is the model/year of your Nissan?
Customer: This is a 2008 frontie
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: The only things I have fixed myself are the cam sensors and battery. Have never had an issue except for the bearings and I had the driver side fixed 2 years ago at a dealer and the passenger side fixed a few weeks ago at a Fireatone tire repair place.
JA: Anything else you want the mechanic to know before I connect you?
Customer: No I think that is it. I just want my*****back so I can get up my driveway again.
Submitted: 1 month ago.
Category: Nissan
Expert:  Greg replied 1 month ago.

Hi, I'm Greg (Indy-Tech).
Welcome to JustAnswer. I'm reviewing your question now, and will post back with your reply ASAP.
Rgds Greg.

Expert:  Greg replied 1 month ago.

Happy new year .

This is probably due to the bearing they replaced even if they dis do it again .

There maybe a connection problem to the wiring in the wheel speed sensor which is part of the bearing .

I have seen that when none OEM Bearings are used or a good top made brand like Moog then the built in wheel speed sensors are the problem .

All you need to do is get your car hooked up to a good scan tool with ABS option and check for malfunction codes

this will confirm our suspicions of a bed sensor in the new bearing.

When the Management system has a malfunction in the ABS system this will deactivate ABS,Slip .and 4X4.

Attached is a photo of the part showing you the fitted ABS wheel speed sensor .

Need further assistance with this issue then please get back to me with the reply box below .
After rating there is no further cost for any other question relating this issue .
Kind regards Greg

Related Nissan Questions