How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris(aka-Moose) Your Own Question
Chris(aka-Moose)
Chris(aka-Moose), Nissan Technician
Category: Nissan
Satisfied Customers: 578
Experience:  16 years of experience
2499435
Type Your Nissan Question Here...
Chris(aka-Moose) is online now
A new question is answered every 9 seconds

On bumpy tracks engine light comes on lose power. dont

Customer Question

on bumpy tracks engine light comes on lose power.
JA: Has your vehicled stalled? Has anyone run a diagnostic test to pull the trouble code?
Customer: dont stall.havent tested.changed turbo hoses .fine for 4 weeks.its ok on the road.
JA: What year is your Turbo?
Customer: 05.
JA: Are you fixing your Turbo yourself? What have you tried so far?
Customer: hoses.fuel filter.oil change.air filter.only happens when on rough terrain.
JA: Anything else you want the mechanic to know before I connect you?
Customer: 150000 k on clock.
Submitted: 1 month ago.
Category: Nissan
Expert:  FIXITMAN replied 1 month ago.

Hello, my name is***** you tell me what kind of vehicle this is.

Customer: replied 1 month ago.
hi Bobby.myvehicle is a Nissan navara 2004 twin cab diesel.bought march this year with 135000k on odometer now done 165000k.in june went on 20 000k trip on some very rough tracks.engine light came on and car lost power.turned engine ofand light went out.and ran fine for a while then repeatedly kept doing it .I replaced turbo hoses as they were in poor codition.this seemed to fix problem.recently went on trip this time on sand and done it again.once on the road has been fine.drove 1000ks home no problems.havent had diog done as light is off now.only seems to happen on rough or sandy surfaces and working hard.can not fined any loose wires .thought turbo might be overheating but runs fine on the road.i change oil every 5000k ond fuel filter.i also use fuel additive.any ideas what could make it do this.thanks steve.
Expert:  FIXITMAN replied 1 month ago.

Thank you. Have you scanned the computer for codes to see what comes up?