How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: Nissan
Satisfied Customers: 24656
Experience:  Over 17 years diagnosing and repairing vehicles.
14928985
Type Your Nissan Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

1995 200SX SE-R, Replaced head, can't get it to start. seems

Customer Question

1995 200SX SE-R, Replaced head, can't get it to start. seems like it's flooding now.
Submitted: 10 days ago.
Category: Nissan
Expert:  peterpete190 replied 10 days ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

Check and make sure all grounds are reinstalled properly.I have run across issues with loose,corroded or poor connections with grounds as some bolt to the back of the head or block.Make sure all wiring is o.k. and no wiring was pinched or damaged in any way.

If this is all o.k. let me know.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 10 days ago.

The engine is grounded. I checked it with a multi meter. I have spark on all cylinders checked with an induction timing light, but it is weak, I have fuel, it cranks and stumbles after sitting for awhile. I have some combustion, because the new plugs are a little dirty with carbon. Checked the ecm ground distribution and all seems fine, according to Alldatadiy

Expert:  peterpete190 replied 10 days ago.

I apologize for the delay.

Have you done a compression test at all?