How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: Nissan
Satisfied Customers: 25350
Experience:  Over 17 years diagnosing and repairing vehicles.
14928985
Type Your Nissan Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

Took 2011 armada platinum in cause passenger seat stopped

Customer Question

Took 2011 armada platinum in cause passenger seat stopped working. They said wiring harness is wrong. Motor is 5 prong harness is 2 prong. Why
JA: Have you checked all the fuses? Do you have a wiring diagram?
Customer: No they are checking
JA: Are you fixing your Armada yourself? What have you tried so far?
Customer: Fuses are fine
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 1 month ago.
Category: Nissan
Expert:  peterpete190 replied 1 month ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

Was the passenger seat working before this issue here and was any wiring changed when the seat stopped working or before it stopped working?

Let me know so we can continue,thanks Pete.

Customer: replied 1 month ago.
Seat was working no wiring issues
Expert:  peterpete190 replied 1 month ago.

And they are saying the reason it is not working is because the wrong wiring was installed am I correct?

Customer: replied 1 month ago.
They are wondering how it worked at all
Customer: replied 1 month ago.
Because connection doesn't match up
Expert:  peterpete190 replied 1 month ago.

That is odd.I do see how there are different seat options on this model here.I suspect the harness installed was incorrect from factory and some how did work for a period of time.It may be that the seat control unit isnt seeing the position signals from the 5 prong motor with a 2 prong harness and has stopped working because of it but it should have never worked.

I would ask them to verify that this is the cause here for sure.I have seen several seat motors fail and cause this issue as well here.But it does sound like you need the correct harness and this may be something they can warranty since it was built incorrectly.I would ask if they can get Nissan involved in covering the costs since it was manufactured incorrectly.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete