How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jay Your Own Question
Jay
Jay, Nissan Technician
Category: Nissan
Satisfied Customers: 18724
Experience:  20+yrs experience with Nissan & Infiniti Trained & Certified.Currently still working for Dealer
10181755
Type Your Nissan Question Here...
Jay is online now
A new question is answered every 9 seconds

96 maxima extended crank when warm and runs rough. Have to

Customer Question

96 maxima extended crank when warm and runs rough. Have to floor it. Starts right up when cold. Previously Fixed an issue with the #6 injector stuck open by replacing the pcm. It appears that cylinder 6 is not firing. Switched injector and coil and still nothing. Compression tests good at 180 on front 3 cylinders. Check engine light on for bank two sensor one. Sensor getting power and ground and tests good.
Submitted: 24 days ago.
Category: Nissan
Expert:  Jay replied 24 days ago.

Hello my name is ***** ***** thank you for your question.

This type of question could be tricky to determine with out using a scanner to monitor some sensor operations and the use of a fuel pressure gauge.

First thing I would check is the brand spark plugs. These engines are sensitive to the brand spark plugs I would make sure it has NGK platinum plugs. Then I would clean and service the throttle chamber. I would also check to see if the car has a after market fuel filter. If it does, I would put a OEM fuel filter in the car. After Market fuel filters can restrict fuel flow.

So lets check those things to start and let me know what you find.

Customer: replied 23 days ago.
Spark plugs are NGK and fuel pressure is within spec. Coolant temp sensor is reading good and the O2 sensor bank two is stuck at 1.3 volts. Bank one is switch between .3 and .9 volts.
Expert:  Jay replied 23 days ago.

What is the fuel pressure? Also did you clean the throttle chamber?

The rear 02 reading is correct, and the front 02's sound right.

Customer: replied 22 days ago.
Throttle chamber was cleaned. Fuel pressure is 35 psi at idle. On the O2 sensors, bank 2 sensor 1 is not switching like it should. Why would it start fine when it's cold and start hard when it's warm?
Expert:  Jay replied 22 days ago.

Do you have a check engine light on when the car is running?

Expert:  Jay replied 22 days ago.

What is the exact code you are getting?

Customer: replied 22 days ago.
P0150
Expert:  Jay replied 22 days ago.

That code is for the Bank 2 front 02 sensor. Did you try clearing this code and see if returns?

Expert:  Jay replied 22 days ago.

I do know that the 96 Maxima's did have some harness issues where it bends behind the passenger strut tower area. So try to wiggle the harness while someone helps to try to start the car when it doesn't want to start or when it takes a while and see if it starts and let me know

Customer: replied 19 days ago.
Code returns when cleared. wiggled and inspected the harness with no change.
Customer: replied 19 days ago.
The problem seems to center around cylinder 6. It does not affect the engine when cut off. All others change the idle. Wiring is good from the computer to the injector and has good spark. As mentioned earlier, compression is good across all cylinders.
Expert:  Jay replied 18 days ago.

This sounds like it may get to involved to handle Online. 96 Maxima's are known to have harness issues as I stated. So I will have to opt out and re-open this question back up to see if any other experts have any info to help you.

thanks Jay!