How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jay Your Own Question
Jay
Jay, Nissan Technician
Category: Nissan
Satisfied Customers: 19049
Experience:  20+yrs experience with Nissan & Infiniti Trained & Certified.Currently still working for Dealer
10181755
Type Your Nissan Question Here...
Jay is online now
A new question is answered every 9 seconds

Nissan 2008 altima no sound. Has power. No cd, radio, aux

Customer Question

Nissan 2008 altima no sound. Has power. No cd, radio, aux jack works
JA: Is this an aftermarket stereo, or did it come with the car?
Customer: It came with the car
JA: Are you fixing your Altima yourself? What have you tried so far?
Customer: I just opened the sound system and checked for any loose contacts
JA: Anything else you want the mechanic to know before I connect you?
Customer: Nope
Submitted: 4 months ago.
Category: Nissan
Expert:  Jay replied 4 months ago.

Hello my name is ***** ***** thank you for your question.

Sorry for the delay. When you are operating your radio does it operate properly but just has no sound?

Customer: replied 4 months ago.
Just no sound. I am able to tune radio, put cd player displays as playing but no sound. While opening myself to see for any loose connection, and when re inserting the cable I heared krick krick at the back speakers alone. (Only at the time of re inserting the cable).
Expert:  Jay replied 4 months ago.

Is this a Bose radio? Does it say Bose anywhere around the radio?

Expert:  Jay replied 4 months ago.

Do you hear the speakers pop when you first start the car?

Customer: replied 4 months ago.
No. The speakers don't pop when I first start the car. The speakers I don't see it saying Bose anywhere. From trunk this is what was there on the speakers (Nissan, EAS23D120A PEDCA, 25 W Mexico etc.,)
Expert:  Jay replied 4 months ago.

Then this is most likely due to a internal amp failure in the radio if the radio is working perfectly but has no sound. If it was a Bose system, you would have a external amp in the trunk. But since you don't see Bose anywhere, that is a Base stereo. So you will need to replace the radio to resolve your issue.

If you have any more questions on this, please feel free to ask.

If not, and you're satisfied with my help, please Rate me. That is how I get credit for my work. I hope I have provided you with Excellent Service.

Thanks Jay!