How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jake Your Own Question
Jake, Nissan Technician
Category: Nissan
Satisfied Customers: 3597
Experience:  Experienced collision repair technician, Pulaski Tech graduate and DSM hobbyist.
Type Your Nissan Question Here...
Jake is online now
A new question is answered every 9 seconds

Complete loss of power with codes p0300 p0037 poo21 it would

Customer Question

complete loss of power with codes p0300 p0037 poo21 it would go over 20 mph all the way home
JA: Just to clarify, what's the exact code? And have you tried to reset it?
Customer: 3 codes p0300 - p0037 -- p0021 yes I have reset them
JA: What is the model/year of your Nissan?
Customer: 2005 maxima
JA: Are you fixing your Maxima yourself? What have you tried so far?
Customer: I am and I have not done anything it happened today so I just started researching those codes
JA: Anything else you want the mechanic to know before I connect you?
Customer: no
Submitted: 1 month ago.
Category: Nissan
Expert:  Jake replied 1 month ago.

before proceeding can you verify your oil level since you have a P0021? make sure it's not low.

also, since you cannot go over 20mph. does it not rev over a certain RPM? does it stay in 5th gear? what exactly is preventing acceleration? please elaborate.

Customer: replied 1 month ago.
oil is normal level, I was manual shifting to maximize the power it had because I couldn't really even touch the gas pedal the more I would push it the more it would bog so I just gently gassed it home. so that's the main problem I cant touch the gas pedal without it completely bogging down, its idling fine it just want go. I was mainly in 2nd gear to pull the hills and never got over 20
Customer: replied 1 month ago.
just to add to that the rpm's never got over 3000 in 2nd that was all it had, before this issue it was having a issue in 5th gear around 50-55 it would shutter when accelerating but only around that speed if I sped up or shifted to 4th it would stop
Expert:  Jake replied 1 month ago.
Thanks, ***** ***** code reader see live data at all?
Customer: replied 1 month ago.
I don't have one, I went to Orileys to get it checked
Expert:  Jake replied 1 month ago.
I see the reason I ask is because you very well could have a MAF issue and the P0037 andP0300 is simply the result of the fuel trim issue of the MAF
Customer: replied 1 month ago.
ok so at this point I was just going to start throwing money at it until something sticks so do you think that is where I should start by replacing the MAF
Customer: replied 1 month ago.
I am going to go ahead and try that its our only car and with 3 kids and a job 30 miles away I have to get this resolved quickly, I will let you know if that works, is that your only suggestion for now is try replacing the MAF thanks
Expert:  Jake replied 1 month ago.
Sorry was eating dinner.I am back, I was really wanting to check fuel trims for the MAF issue as I don't generally throw parts at stuff without a diagnosis but with limited resources we may have to.For what it's worth the symptoms you describe are common symptoms of a MAF failure and two of the codes are a common result of fuel trim issues from a MAF.
Expert:  Jake replied 1 month ago.
The only code that's odd is the IVT code. Which is generally from low oil, sludge, or a timing issue.
Customer: replied 30 days ago.
I changed the MAF ($150) and there was no change I drove the car for about a mile after resetting the computer and as of now there is no check engine light but its still doing the same, starting and idling good but no way to drive except barely touching the pedal and then it only gets to about 20 mph if you push any harder then the engine gets restricted like bogging not sputtering or anything just want let you accel at all, do you have a suggestion to try next, I can get to a parts store to rent any testers I may need. thanks for your help
Expert:  Jake replied 30 days ago.
That is certainly unfortunate and the reason I was hoping to check fuel trims first.
Expert:  Jake replied 30 days ago.
I certainly have other ideas.Are you familiar with the IVT solenoids? Have you tried tapping them when the engine is running?
Expert:  Jake replied 30 days ago.
The reason I say that is because tapping the solenoid can rule out if it's getting stuck. If it's not, then you can pretty much guarantee that either the bank 2 cam sensor is the problem or the bank 2 timing tensioner is loose cause that banks timing to be out slightly.
Customer: replied 28 days ago.
to be sure because I couldn't tell I replaced the IVT solenoid on bank 2 (or left) and replace the bank 2 cam sensor, neither made any change, I do hear lifters when its started and running although the oil is full and its only been a few weeks since I changed it I'm not sure how that is related but I just noticed it and its pretty loud when your under the hood. so can you advice what you would do next I really appreciate its getting expensive quickly so I hope together we can find it but I am willing to do whatever is needed thanks. I live in a rural area and to get it to a mechanic or dealer would be 30 miles and I really cant afford to be down long
Expert:  Jake replied 28 days ago.
Wow, This is generally why if it's something difficult and you have no equipment to test with that's it's best to pay the labor to someone who does.
My biggest fear here is it could be related to an issue with the upper timing chain for that bank, and short of removing the front cover you need a scan tool to watch intake timing readings.
Expert:  Jake replied 28 days ago.
You could get lifter noise if the oil pressure is low. Which can be caused by rear timing cover leaks

Related Nissan Questions