How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jake Your Own Question
Jake
Jake, Nissan Technician
Category: Nissan
Satisfied Customers: 3655
Experience:  Experienced collision repair technician, Pulaski Tech graduate and DSM hobbyist.
20440119
Type Your Nissan Question Here...
Jake is online now
A new question is answered every 9 seconds

I have a 2006 Xterra auto with 189,000. All of a sudden, the

Customer Question

I have a 2006 Xterra auto with 189,000. All of a sudden, the car will not go into gear. At all! It just revs up and sounds like it is in neutral. I ran a code and got a P0717. Input speed sensor. Would this be the "neutral" problem? Is the sensor easy to change?
Thanks
Submitted: 3 months ago.
Category: Nissan
Expert:  Jake replied 3 months ago.

Hey there, thats the turbine revolution sensor which detects input shaft speed and can definately cause your problem.

Expert:  Jake replied 3 months ago.

The sensor is not easy to change, it's very difficult as it's INSIDE the transmission on this year xterra. The part is also hard to find by itself because it attaached to the main control valve and is usually replaced as an assembly. That unfortunately is like $900 !!

Related Nissan Questions