How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim Mohr Your Own Question
Tim Mohr
Tim Mohr, ASE MASTER TECH
Category: Nissan
Satisfied Customers: 560
Experience:  30 YRS EXPERIENCE, FOREIGN AND DOMESTIC, GAS AND DEISEL
17454363
Type Your Nissan Question Here...
Tim Mohr is online now
A new question is answered every 9 seconds

I have a nissan altima 2006 2.5 i have code dtc p0001, crank

Customer Question

i have a nissan altima 2006 2.5 i have code dtc p0001
JA: Just to clarify, what's the exact code? And have you tried to reset it?
Customer: crank no start
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: yes
JA: Anything else you think the mechanic should know?
Customer: i changed the fuel pump already and the camshaft too still not working when i spray into the engine its work and stop. what could be the problem?
Submitted: 4 months ago.
Category: Nissan
Expert:  Jay replied 4 months ago.

Hello my name is ***** ***** thank you for your question.

Has the oil level been checked to see if it's low on oil? Also since you had Cam Sensor replaced recently, who did the work and do you know where the sensor was brought?

Customer: replied 4 months ago.
I recently put it in
Customer: replied 4 months ago.
the pump is running no pressure
Expert:  Jay replied 4 months ago.

If you are now getting this code after installing the cam sensor and that cam sensor is after market, that is your problem. After Market cam sensors are known to cause intake timing codes and make you think it's the timing chains when it's the sensor.

What do you mean no pressure? Did you do a oil pressure test?

Customer: replied 4 months ago.
I brought it from advance
Customer: replied 4 months ago.
I checked the oil pressure test
Expert:  Jay replied 4 months ago.

If you didn't buy the sensors from the dealer, they are after market.

At idle you are only going to see around 11psi of oil pressure which is normal.

Customer: replied 4 months ago.
I am not getting any prensure and the fuel pump is running
Expert:  Jay replied 4 months ago.

You removed the oil pressure switch and you are checking pressure in that port correct?