How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jay Your Own Question
Jay, Nissan Technician
Category: Nissan
Satisfied Customers: 18547
Experience:  20+yrs experience with Nissan & Infiniti Trained & Certified.Currently still working for Dealer
Type Your Nissan Question Here...
Jay is online now
A new question is answered every 9 seconds

I have 300zx, and I did swab from NA to TT, I meant swap,

Customer Question

JA: Hi. What is your issue regarding?
Customer: I have 300zx
JA: What is the model/year of your Nissan?
Customer: and I did swab from NA to TT
JA: What year is your Nissan?
Customer: I meant swap
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: 1991
JA: Anything else you think the mechanic should know?
Customer: its crank but not start
JA: Have you checked the fuel supply? And are all the spark plugs working?
Customer: sometime start for 2 sec with 300 RPm
Submitted: 3 months ago.
Category: Nissan
Customer: replied 3 months ago.
Customer: replied 3 months ago.
Fuses were good
Crank sensor ok
Customer: replied 3 months ago.
sparks plugs are replaced
Expert:  Jay replied 3 months ago.

Hello my name is ***** ***** thank you for your question.

The most common cause of a No Start issue on a 91 300zx is the power transistor. If the recall was done back in the 90's it would be zip tied to the upper radiator hose. If not, it would be bolted to the front timing cover. This was the most common cause for no start issues.

The only other thing I would check is the timing belt. If that broke, the engine would not start either and you would be looking at internal engine damage.

Do you have any more questions on this?

Customer: replied 3 months ago.
The power transistor is good and i replace it with other one and same resultHow do i know if there are prablem in my timing belt?
Case this engine came from overhauling with new timing belt !
Customer: replied 3 months ago.
I checked the timing belt and found it okthe engine run for almost 300 RPM and just die immediately
Expert:  Jay replied 3 months ago.

Has the MAF sensor been checked?

Customer: replied 3 months ago.
today I checked ECU again and it show code 21
I checked the ignition spark by remove all 6 coil and all are showing spark !!
I check crank sensor and once I rotated it by my hand I feel the click sound came from all injector one by one
If PTU damage why there are sparks in all coils ?!
Expert:  Jay replied 2 months ago.

That code 21 points to the power transistor which is what I originally said.

Customer: replied 2 months ago.
I replace it with other PTU and still same issue....
I checked the coil with spark plug and its giving spark
So its not PTU problem !
Expert:  Jay replied 2 months ago.

Do you have injector pulse? Where are you getting the Power Transistors you tried?

Customer: replied 2 months ago.
I m getting injector pulse and coil spark when I rotate CASPTU used one
Expert:  Jay replied 2 months ago.

Have you checked fuel pressure? or condition of fuel by taking a fuel sample?

Customer: replied 2 months ago.
Fuel pump is working
But I didn't check the pressureOk I will check it
Expert:  Jay replied 2 months ago.

You want to see what kind of fuel pressure you are getting. Also make sure the fuel filter is not restricting flow.