How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190, Auto Technician
Category: Nissan
Satisfied Customers: 24200
Experience:  Over 17 years diagnosing and repairing vehicles.
Type Your Nissan Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

Temperature gauge still fluctuates, stalls even after

Customer Question

temperature gauge still fluctuates, stalls even after replacing crank sensor also replaced Vias soenoid because got p1800 code it passed emission but after a day or two it started back
JA: How many miles are on the car? Has the thermostat ever been replaced?
Customer: 149.000
JA: What is the model/year of your Nissan?
Customer: 2004 3.5 SE I thought about the thermostat just put new radiator in
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: i was trying to fix it myself, but as i have told you i have been replacing parts but problem still here
JA: Anything else you think the mechanic should know?
Customer: nothing but when it stall it starts right back up and when setting still jerks a little great car just trying to figure out whats going on?
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Nissan Mechanic about your situation and then connect you two.
Submitted: 4 months ago.
Category: Nissan
Customer: replied 4 months ago.
are u still there
Expert:  peterpete190 replied 4 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

One common cause for this issue here can be a fault with the engine coolant temp sensor.If this sensor was not checked into to see if it was the fault this needs done and replaced if found to be the issue.If this was already checked or replaced let me know.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete