How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jake Your Own Question
Jake
Jake, Nissan Technician
Category: Nissan
Satisfied Customers: 3646
Experience:  Experienced collision repair technician, Pulaski Tech graduate and DSM hobbyist.
20440119
Type Your Nissan Question Here...
Jake is online now
A new question is answered every 9 seconds

My 2001 nissan exterra has a problem where when it is run

Customer Question

My 2001 nissan exterra has a problem where when it is run alot it won't advance and states that it is overheating even when radiator and the reserve tank is full and will turn off and not run until the motor cools down.
I took it to a mechanic but he changed the catalysts and then said that it was the timing chain but none of these things seemed to work. I was wondering if maybe it was a sensor or the fuel injectors?
Submitted: 5 months ago.
Category: Nissan
Expert:  Jake replied 5 months ago.

hey there, thanks for the question.

Customer: replied 5 months ago.
Yw
Expert:  Jake replied 5 months ago.

So what are saying by it "won't advance"

Expert:  Jake replied 5 months ago.

are you referring to the fact that it won't accelerate? or won't build RPM's? or will it not move at all?

Customer: replied 5 months ago.
that's it
Expert:  Jake replied 5 months ago.

Does the engine actually stall out when this happens? or does it continue to idle fine, but won't accelerate?

Customer: replied 5 months ago.
Sometimes it stalls out and sometimes it idles fine and won't accelerate
Expert:  Jake replied 5 months ago.

Do you know what trouble codes were present when it was scanned?

Customer: replied 5 months ago.
No I wasn't told the codes
Expert:  Jake replied 5 months ago.

Codes would be extremely helpful at this point, but since you have none I can tell you a couple similar situations I have seen and what you can do to help find out which one best suits your predicament.

Customer: replied 5 months ago.
That would be nice thank you
Expert:  Jake replied 5 months ago.

If the engine sometimes stalls, but will not build RPMS when this happens. This is a good indication of a MAF problem. If it falls out of spec it will cause the fuel trims to be dramatically off and bog severely to where you can't rev up the engine.

Now if the vehicle won't move, but you can still rev the engine fine in all gears, then your looking at a transmission issue. Could be electrical causing a fail-safe condition.

Lastly, if the engine will still attempt to rev, but the RPMS seem erratic and jumpy and the engine just runs poorly all together. You need to inspect the distributor. Sometimes the shaft seal will leak on them and allow oil to slowly seem into the distridutor when driving. This will cause issues with the cam sensor in the distributor.

Expert:  Jake replied 5 months ago.

Best place to start unfortunately is either by see what all you CAN and can't do when it happens or to scan for codes when it happens.

Expert:  Jake replied 5 months ago.

If you run into any more questions later or get the codes from the mechanic and would like another opinion afterwards let me know.

I will be happy to help.

Customer: replied 5 months ago.
Oh yes I had the mechanic change the distributor the spark plugs and their wires
Customer: replied 5 months ago.
what sensor would I be looking for?
Customer: replied 5 months ago.
Are you still there?
Customer: replied 5 months ago.
Hello
Expert:  Jake replied 5 months ago.

Hey there, i tried to respond to your original question the day you posted it, but it said CLOSED.

Wasn't sure if you asked customer service to close it or what.

Let me know if you still need help.