How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chad Farhat Your Own Question
Chad Farhat
Chad Farhat, ASE Certified Technician A6 - Electrical / Electronic systems A7 Heating / Air conditioning systems
Category: Nissan
Satisfied Customers: 1531
Experience:  Owner at Carolina Auto Service & Sales , 20 years Experience in Foreign & Domestic vehicles
45790705
Type Your Nissan Question Here...
Chad Farhat is online now
A new question is answered every 9 seconds

2002 maxama with 147k, slip and tcs off light keep coming on

Customer Question

2002 maxama with 147k, slip and tcs off light keep coming on and off, when they come on engine stalls then is hard to restart, but seems to run fine, ses light is always on, just passed smog 12.5 at the battery 13.5 when running.
JA: Is the check engine light on? Does the car stall at idle or when driving?
Customer: yes
JA: What is the model of your '02 Nissan?
Customer: Maxima GLE
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: tried nothinh
JA: Anything else you think the mechanic should know?
Customer: tried nothing so far, i have acess to a couple of Nissian techs in town but have not talked to them yet. had passenger air bag replaced last year, dealer was horrible, replaced o2 sensor last year too solved the ses light but its back on.
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Nissan Mechanic about your situation and then connect you two.
Submitted: 5 months ago.
Category: Nissan
Expert:  Chad Farhat replied 5 months ago.
Hi my name is ***** ***** I will be assisting you todayHave you had the fault codes retrieved from the abs module ?Thanks
Chad (aka-Jhook1398)
Expert:  Chad Farhat replied 5 months ago.
You can have one the wheel ABS sensor intermentily pickin up speed signal , causing this, but retrieval of fault codes is essential here ,can you do that and let me know what they are and I can help you furthere, a capable scanner can hook up to abs pump and drive Dow the road and check if it is working on his scanner screenThanks
Chad(aka-Jhook1398)
Customer: replied 5 months ago.
no
Expert:  Chad Farhat replied 5 months ago.
Can you get it scanned and let me know what they are ?
Expert:  Chad Farhat replied 5 months ago.
There is sacral components in system ,abs module, abs sensor, steering angel sensor,yaw sensor etc... To many to check individually
It could be any of them or it could be in the connector to the abs pump I seen that on this car having defective abs pump or connector
But testing is needed to confirm
Customer: replied 5 months ago.
I will get it scaned, thanks
Expert:  Chad Farhat replied 5 months ago.
Ok coolI m online daily from 10 am till 12 pm
If I m out in the field, it might be 30 min or an hour to get back to you ,but just post the codes back here and I will see it and we can continue thenThanks
Chad