How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: Nissan
Satisfied Customers: 24725
Experience:  Over 17 years diagnosing and repairing vehicles.
14928985
Type Your Nissan Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

I bought a nissan liberty and it it an automaticone from

Customer Question

I bought a nissan liberty and it it an automaticone from Japan. for a while it was okay. Now when you start it from cold it drives a distance of aproximately 30 to 40km then it stops changing gears and drives on low gears which could be gear number 2 or 3.
JA: How many miles are on the car? How old is the battery? Are you hoping to fix this yourself?
Customer: The miage on the dash now is 73079. Yes i was hoping to fix it myself if it does not require dismantling the gear box.
JA: Great! What have you tried so far?
Customer: I changed the transmission oil but i did not find an filters. So the filters were not changed.
JA: Is there anything else the Mechanic should be aware of about your nissan?
Customer: It was connected on the diagnostic computer but they did not find any electrical faults and thats all i have tried so far.
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Mechanic about your situation and then connect you two.
Submitted: 6 months ago.
Category: Nissan
Expert:  peterpete190 replied 6 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

Usually in most cases a fault like this here is caused by an issue with a shift solenoid in the transmission or another sensor or solenoid at fault or the transmission valve body in some cases.It sounds like it is going into a "limp mode" due to it failing to up shift and being able to shut it down and restart it to allow proper operation.

If there were no codes set unfortunately this will have to be tested diagnosed further by a transmission repair facility or dealer with their test tools like a transmission fluid pressure gauge and other test equipment to locate the fault.Then it can be determined from there if this is something you can repair or if they need to repair it as some transmission work may require special tools to take it apart and repair it unfortunately.

Valve body failure can be common in some cases.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 6 months ago.
Can you help me identify where the solonoid you mentioned on your second paragraph is located.?
Expert:  peterpete190 replied 6 months ago.

Can you tell me the year,model and engine size and I will see if I can locate a diagram of these solenoids?

Let me know,thanks Pete