How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chad Farhat Your Own Question
Chad Farhat
Chad Farhat, ASE Certified Technician A6 - Electrical / Electronic systems A7 Heating / Air conditioning systems
Category: Nissan
Satisfied Customers: 2719
Experience:  Owner at Carolina Auto Service & Sales , 20 years Experience in Foreign & Domestic vehicles
45790705
Type Your Nissan Question Here...
Chad Farhat is online now
A new question is answered every 9 seconds

I own a 2003 Nissan 350z and I replace the rear o2 sensor

Customer Question

I own a 2003 Nissan 350z and I replace the rear o2 sensor for the dtc p0037 and it wont go off and I checked all my fuses in the car and e
there all good
Submitted: 11 months ago.
Category: Nissan
Expert:  Chad Farhat replied 11 months ago.

Hi My Name is***** will try to assist you

Customer: replied 11 months ago.
I have a 03 Nissan 350z I have code p0037 and replaced passenger rear o2 sensor and cleared the code but comes on so I checked fuse and they are all good
Expert:  Chad Farhat replied 11 months ago.

is this the only code on P0037,u replaced ( Right Passenger Rear correct

Expert:  Chad Farhat replied 11 months ago.

did you buy OEM sensor or Aftermarket , ? thanks

Customer: replied 11 months ago.
I replaced it and code still comes on
Expert:  Chad Farhat replied 11 months ago.

do u have a scanner where you can read data stream and pull up the o2 sensor and tell me what is it doing , is switching from 100mv to 900mv or 0 to 1v ?

Expert:  Chad Farhat replied 11 months ago.

is the car running rough , any hesitation , have u pulled plugs and checked of any fuel on them or she just driving perfect and light on and it is always P0037

Customer: replied 11 months ago.
none of my 4 o2 sensor are reading 1v the close they get is to .9v
Expert:  Chad Farhat replied 11 months ago.

yes .9 v it want reach 1v on scanner , are the front one ,upstream ones switching quickly and the rear one are slower switching from .1 to .9 ?

Customer: replied 11 months ago.
she drives perfect not rough on idle just the light is on and always the same code p0037
Customer: replied 11 months ago.
sir
Expert:  Chad Farhat replied 11 months ago.

I hate to tell you this but I had 2 case of nissan 350z , same issue code P0037 , changed the sensor 3 times ,checked power , everything perfect , you drive few miles , and it throws is again , what we found that when car cold the ecu grounding the sensor and its working but when car warms it loose the ground , so took it to dealer they confirmed our findings also , he ordered new ecu , install, Same code , he ordered another a 2ND ecu and new sensor same problem. so the only thing left was the wiring harness but my customer did not want to do it ,and i advised against just way to much money for a problem not effecting drivabilty ?

Expert:  Chad Farhat replied 11 months ago.

it could be a problem in the harness, or ecu software , i think even they called nissan tech and they were puzzled , i just feel it is too much of parts changing at this time since they cant find why . i m not saying that is what is happening to yours but , that is my experience with it on this sistuation, i m sorry i hated for you , but the car drive good let her be , i know the light sucks to have on, if u get a cobb tuner , u can make a new tuning map and erase the o2 sensor :)

Customer: replied 11 months ago.
see I have to run it thro emissions tomorrow and really don't know if I erase it before I run it thro emission will they be able to detect it
Expert:  Chad Farhat replied 11 months ago.

no erase right before u go in and if i was u go park hours before let the car be cold and then take it in

Expert:  Chad Farhat replied 11 months ago.

A POSITIVE RATING IS MUCH APRECIATTED

THE POST WILL STAY OPEN FOR U TO COME BACK AND ASK FOLLOW UP QUESTION FREE OF CHARGE ON THIS ISSUE .

THANKS .

Expert:  Chad Farhat replied 11 months ago.

I HAD A COBB TUNER IN MY SUBARU STI AND I HAD MY O2 DELETED FROM THE SOFTWARE

Expert:  Chad Farhat replied 11 months ago.

IT IS WORTH A SHOT CLEAR IT BEFORE U GO IN

Expert:  Chad Farhat replied 11 months ago.

I WISH THERE WAS A QUICK FIX TO TELL YOU TO GET RIDE OF IT , SORRY

Expert:  Chad Farhat replied 11 months ago.

WE ALSO TRIED RUNNING WIRES FROM ECU TO O2 FROM WHAT I REMMBER & IT STILL THROWED IT .

LET ME KNOW WHAT HAPPENS WITH EMMSION TEST , .GOOD LUCK .

PLEASE REMMBER TO POSITIVILEY RATE ME IF U WERE SATISFIED WITH MY SERVICE SINCE THAT IS HOW WE GET COMPENSATED . THANKS AGAIN

Expert:  Chad Farhat replied 10 months ago.

hey ,so did u take to emission test and did you pass it