How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jay Your Own Question
Jay, Nissan Technician
Category: Nissan
Satisfied Customers: 18553
Experience:  20+yrs experience with Nissan & Infiniti Trained & Certified.Currently still working for Dealer
Type Your Nissan Question Here...
Jay is online now
A new question is answered every 9 seconds

Nissan frontier: I replaced a thermostat on my 2002 nissan

Customer Question

I replaced a thermostat on my 2002 nissan frontier Se 3.3L V6 (non SC). Installation went fine, but as i went to start the engine, the re is no power to the dashboard or starter. I have checked all fuses and they are good. All connections are tight and clean since the only connection i removed was the negative battery cable. I did however place the negative connection on the battery clamp screw which might have caused the battery current to go through the vehicle frame. I am out of knowledge.
Submitted: 5 months ago.
Category: Nissan
Customer: replied 5 months ago.
(Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 5 months ago.
No need to call just need help quickly please
Expert:  tracker40 replied 5 months ago.
Hello, I have to pull diagrams etc so can not be a super fast fix so,, can you tell me everything not working? lights? wipers, windows, blower? brake lights and so on?
Customer: replied 5 months ago.
Lights work, turn signal no, wipers no, windows no, brake lights yes, horn yes, anything on the dashboard does not work. It beeps when i put the key in but when i turn it there is.nothing
Expert:  tracker40 replied 5 months ago.
Possible main fuse link, It is bolted in, Possible one of the HIGH amp fuses like 80 amp 40 amp etc, They are hard to see if bad looking at them so,, I suggest moving some fuses around and see if you regain anything not working, If the main link is bad?> then you have to unbolt it, Here is a link to a video but may not match your fuse box 100% but gives idea what I refer to, I wiould go to under hood fuse box, change or move around the high amp fuses, The 80 amp may be bad, Its going to be one of the high amp fuses or fuse link, Her is also a link to picture of the fuse box. The main fuse link is the 100 amp fuse in the middle,. Most all parts stores sell themVideo link below. need to copy paste that link
Customer: replied 5 months ago.
I took the battery fuse out that you mentioned and inspected it and also did a continuity test, and it is good. I checked all fuses, and everything is good.
Expert:  tracker40 replied 5 months ago.
then I have to opt out, if you swapped fuses as mentioned and not looked at them>? then I do not know, Another expert should be long soon to help
Customer: replied 5 months ago.
Ok thanks
Expert:  Jay replied 5 months ago.
Hello my name is ***** ***** thank you for your question. Do you still need help with this?
Customer: replied 5 months ago.
I replaced the battery fuse still nothing. I replaced my thermostat this last friday. I disconnected the negative terminal but i believ it may have come in contact with metal so current might have been disspating into the frame. I am not sure what that would damage. I have head lights and power to starter. I have no turn signals. Power windows, the dashboard is also out.
Customer: replied 5 months ago.
All connections are tight, could the current discharging into the frame damage my ECU? I am out of knowledge
Expert:  Jay replied 5 months ago.
Did you check all fusible links?
Customer: replied 5 months ago.
Yes all fuseable links are good. I did a continuity check onbthe ignitoan also and it is good. I am getting power to the starter also.
Expert:  Jay replied 5 months ago.
If you turn the key to the ON position, does all the dash warning lights come on?
Expert:  Jay replied 5 months ago.
Do you have a test light?
Customer: replied 5 months ago.
No dash board lights, radio, and ignition. I have horn, regular lights, interior lights. I did a continuity check on the ignition switch and it appears to be good also. It has a brand new battery.
Expert:  Jay replied 5 months ago.
Do you have a test light to check all fuses?