How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Nissan
Satisfied Customers: 34473
Experience:  34 years of automotive Repair
7276279
Type Your Nissan Question Here...
Ron is online now
A new question is answered every 9 seconds

I have replaced my tps sensor, cleaned the throttle boy chamber,

Customer Question

I have replaced my tps sensor, cleaned the throttle boy chamber, had all plugs, wires, cap, rotor, & valve cover gasket replaced. Along with cam & crank sensor. Since then every time you start car it starts around 3,000 rpm after 8-10 min drops to 1,500 & after few more min goes to normal. If you don't it feels like the engine is going to jump through the dash board
JA: Sometimes things that you think will be really complicated end up being easy to fix with a Nissan. The Nissan Mechanic I'm going to connect you with knows all the tricks and shortcuts. Are you hoping to fix this yourself?
Customer: This si also the 2nd tps sensor I had installed the 1st made rpms jump from 1.5-2.5 just going 20mph, Nissan said I hay have defective one again
JA: Is there anything else the Nissan Mechanic should be aware of about your Nissan?
Customer: just that I am spectical on trusting anyone, with the suspension work I did was over $2k & now car sruns worse than before
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Nissan Mechanic about your situation and then connect you two.
Submitted: 11 months ago.
Category: Nissan
Customer: replied 11 months ago.
Now every time it shifts from 1st to 2nd & 2nd to 3rd it shifts hard. Like the timing is off. i have relearned the idle severaltimes. Recently it is misfiring more 7 more, stalling & shuttering even while driving
Customer: replied 11 months ago.
I thought it was possible for a 2nd bad tps sensor. But now am thinking possible idle air control vale or the speed sensor, as recently neither of my radiator fans are working? So as well as running terrible it is running HOT & wants to overheat! PLEASE HELP
Customer: replied 11 months ago.
Thought you should know it is a 2000 Nissan Altima GXE with 233,000 miles.
Customer: replied 11 months ago.
Also I was directed to your site for location of IACV, then an instant chat came on & I even elected to the Premium Service of $50.00 after 7 day free trial to get unlimited answers & response within 5 minutes?
I am at work now but will respond within minutes of you responding to me..... I need this car to run right & not over heat. I thought I was doing right by putting $2,000 into it not including tires & alignment.
Expert:  njerje23 replied 11 months ago.
..
Customer: replied 11 months ago.
What bulb? There is no broken bulb?
Expert:  njerje23 replied 11 months ago.
sorry about that, somehow the site posted the wrong answer to your question, my apologies!
Customer: replied 11 months ago.
ok was confused there
Customer: replied 11 months ago.
again I am at work & cannot call can type
Customer: replied 11 months ago.
So? my car NEVER shifted hard or ran at such high rpms. Do you think I am right on the idle air control valve, I thought it was speed sensor but was unsure. Also can the speed sensor cause no fans to run w/ my radiator fans? It was working fine & even had AC, now does not have any AC, the light o the button on the dash don't even come on. I do have heat & it blows out fine & all of my relays are good. Thought was fan motor, it just does NOT come on at all. But then read speed sensors if malfunctioning can cause fan motor to not work
Customer: replied 11 months ago.
Are you there? Please I have waited almost 2 hours for a response & a call does not work for me today. The chat person chatted with me 1st & no one has really responded at all???
Expert:  Ron replied 11 months ago.
Hello and thank you for your question, different expert here.Has the computer system been scanned and if so are you getting any fault codes?
Customer: replied 11 months ago.
I am sorry I cannot take calls at work, I am not sure if it automatically posts that for you guys. But the last 2 scans I have done all 3 are throttle position sensor codes still
Expert:  Ron replied 11 months ago.
Im not asking you for a phone call, can you give me the actual fault code and or codes your getting when you scanned it?
Customer: replied 11 months ago.
Ok sorry it must auto post that for you, but yes they are down in my glove box, I am going on lunch in 20 minutes & can bring them to my desk.
Customer: replied 11 months ago.
Apologize I want to just give up on the car but I have no other option with all the money I have put into it & then to have no way to get my kids around ya know
Expert:  Ron replied 11 months ago.
When you can get to it, post back with the fault codes and we can work from there. Im here all day.
Customer: replied 11 months ago.
Ok great! Awesome! Thank you
Expert:  Ron replied 11 months ago.
Your very welcome.
Customer: replied 11 months ago.
Hello the TPS codes are P0120, P1705 & P1705 not sure why it had the last one twice? Also since installing new TPS the OD light blinks 16 times every time I start the car, mechanic told me to not worry about that, why after searching had me thinking it was speed sensor. Along with my fans no longer working at all.
Expert:  Ron replied 11 months ago.
Both of these codes can be set due to any of the following, Idle SwitchThrottle Position SensorThrottle Position Sensor (TPS)Throttle Position Sensor (TPS) AdjustmentIn order to determine the cause you are going to need to do some testing. See the steps in the link below. Copy and paste the link to your browser to open and view them.https://dl.dropboxusercontent.com/u/104923897/TP%20code%20Apr%2029.pdf
Customer: replied 11 months ago.
Ok I will thanks and the "mechanic" I took it to that fixed this told me the TPS cannot be adjusted. Am I correct in thinking he's been wrong all along? And would the tps error cause the OD light to blink 16 times when it starts?
Expert:  Ron replied 11 months ago.
It can ba adjust by changing the throttle hard stop. The OD light blink is not likely related to the TP codes and or concern.
Customer: replied 11 months ago.
Ok & thank you for that. I will have to attempt this tomorrow as you know I am at work, and my boys have their 1st school dance tonight. But will see how this goes. :)
Customer: replied 11 months ago.
unrelated but the just ask website said it was $5 & free week trial, but my card was charged for $5 & then another $15? So will be contacting them...
Expert:  Ron replied 11 months ago.
Yes please contact customer service for pricing concerns. I have no control over that and I am paid nothing unless you rate my service.
Customer: replied 11 months ago.
It's ok & understand, I wil contact them & be sure to rate you great after this test I'm sure you'll hear from me
Expert:  Ron replied 11 months ago.
Sure thing, Im here if you need me. The question remains open for as long as you need me even after you rate my service.