How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: Nissan
Satisfied Customers: 24668
Experience:  Over 17 years diagnosing and repairing vehicles.
14928985
Type Your Nissan Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

Altima: 05 altima stop running will turn over but not firing,

Customer Question

05 altima stop running will turn over but not firing, replaced crankshaft sensor and not start, code showed camshaft sensor bank 2 , replace no start, checked for spark, no spark, unplug crank shaft sensor and will try to start and run a little, ideas?
Submitted: 7 months ago.
Category: Nissan
Expert:  peterpete190 replied 7 months ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here. If you have not checked for any blown fuses or missing ignition or computers fuses in all fuse panels this needs done.If any fuses are found to be blown or missing they will need installed/replaced to see if this corrects the fault here.If these are all o.k. let me know the fault code number that has set with this issue here so we can continue. If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete
Customer: replied 7 months ago.
Code for camshaft sensor bank 2 and inlet air temp, have already changed camshaft sensor and will not crank with it connected but will crank after unplugging, but starts out in a higher gear and have to switch to man shift to try to get to lower gear, sometimes works. If you hook camshaft sensor back up while running it will continue to run but trams still has problem. Once you kill the engine it usually will not crank again until camshaft sensor unplugged again.
Customer: replied 7 months ago.
(Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  peterpete190 replied 7 months ago.
I apologize for the delay. O.k.,check for any shorted or damaged wiring leading to the cam sensor and on the engine and engine components.If any shorted or damaged wiring is found this will need to be repaired to correct this fault here.If this is or was checked and is found to be o.k. let me know so we can continue from here. Let me know if you need anything else and feel free to rate my help here. Thanks Pete

Related Nissan Questions