How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris(aka-Moose) Your Own Question
Chris(aka-Moose), Nissan Technician
Category: Nissan
Satisfied Customers: 43866
Experience:  16 years of experience
Type Your Nissan Question Here...
Chris(aka-Moose) is online now
A new question is answered every 9 seconds

Nissan sentra: I recently bought a 2010 sentra that had been

Customer Question

I recently bought a 2010 sentra that had been involved in an accident. I got a really good deal, but ive changed the front impact sensor, the airbag, the airbag module and both the front seatbelts. Ive attempted to erase the srs light with my scan tool. The light shuts off for a few seconds and comes back on. I get codes B1086, B1089, B1035 and B1088. Im wondering what else could need to be changed to make that srs light disappear for good?
Submitted: 6 months ago.
Category: Nissan
Expert:  Chris(aka-Moose) replied 6 months ago.
Welcome, I'm Chris (aka Moose). I normally log in after 3 pm central. Please make sure to let me know exactly what is needed from me so I can provide EXCELLENT 5 STAR service. Have you done any of the diag steps for these codes yet, if so do you know those results?
Customer: replied 6 months ago.
I changed the pretensioner on both the right and left side, the front impact sensor behind the grill, i also changed the airbag diagnosis unit. All wiring is is secure and in good condition that run to these parts.
Customer: replied 6 months ago.
The srs now blinks instead of being solid after charging these parts but will not erase. When i do erase it, the light is never gone longer than 5 seconds or so
Expert:  Chris(aka-Moose) replied 6 months ago.
Can you do the steps below? believe your going to find the wiring to the drivers front pre tensioner damaged and to blame. -------------------------------------------------------------------------------------On your screen at the top you should see a rating 1-5 stars and a green submit button. Please make sure to select one and press submit. I am not compensated by the website unless a customer rates. Rating only pays me from the deposit you have already made, it does not charge you more, nor close the post. Also all follow ups are free and welcome.Thanks Chris
Customer: replied 6 months ago.
Both pretensioners were changed. Wiring is intact. Air bag diagnosic unit also brand new. Could the clock spring be the issue? It does not appear damaged.
Expert:  Chris(aka-Moose) replied 6 months ago.
The codes do not point to the clock spring. Did you OHM test the pre tensioner wiring back to the module?
Customer: replied 6 months ago.
i have not tried that. i will give that a shot see what happens. Would a weak battery cause this problem?
Expert:  Chris(aka-Moose) replied 6 months ago.
A weak battery would not cause these codes.
Expert:  Chris(aka-Moose) replied 6 months ago.
Hello again Chris here,1) When customers come to Just Answer the website and the experts want them to have a great 5 star experience.2) We also want them to be so pleased that they come back for future needs.3) I have the feeling you were not pleased with my help because no rating was selected and or need me to help more. If so please do reply.4) I have an option to upload diagrams, repair guides, find a repair facility, or call you if that would help. Thanks Chris

Related Nissan Questions