How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jay Your Own Question
Jay, Nissan Technician
Category: Nissan
Satisfied Customers: 18529
Experience:  20+yrs experience with Nissan & Infiniti Trained & Certified.Currently still working for Dealer
Type Your Nissan Question Here...
Jay is online now
A new question is answered every 9 seconds

I have a 2002 Nissan Altima 2.5 4 cyl and have been having

Customer Question

Hi, I have a 2002 Nissan Altima 2.5 4 cyl and have been having trouble. The cel light would come on at random times and it would go into limp mode. The codes were p1705 po507 and p2138. I installed a new complete gas petal and all was well for a short time. The cel came back on and limp mode again. I then installed a new throttle body assembly. After clearing the codes and attempting to do the relearn procedure, I keep getting a code p1225, p1121,and p1122. I can clear them, but it comes right back up. After doing some wire inspections I found a part of a harness was laying against the metal A/C line on the passenger side and had rubbed through the insulation on three wires, orange, green and white with a black tracer, and I think this may be where the problem started. I cleared the wires away from the a/c line and separated them from each other, but Nothing has changed. What I found is the orange wire has no voltage. The car idles rough, and won't even go into gear without stalling. If I clear the code, it smoothes right out for about 3 seconds. I,ve checked all the fuses and didn't find any blown.
Submitted: 7 months ago.
Category: Nissan
Expert:  Jay replied 7 months ago.

Hello my name is ***** ***** thank you for your question.

This type of issue may get involve. Can you send me a picture of the area where the harness was damaged?

Also did you try a idle relearn?

Customer: replied 7 months ago.
I did try the relearn a number of times
Customer: replied 7 months ago.
I'm thinking I need to check the voltage on the wires that plug into the throttle body but I don't know what voltage they should be.
Expert:  Jay replied 7 months ago.

That is the complete diagnostics for the codes you keep getting so you can go through and check the wiring as well.

Let me know if you have any more questions on this.

If not, and you are satisfied with my help, please rate me. I hope I have provided you with excellent service.

Thanks Jay!

Customer: replied 7 months ago.
I am working out of town this week so it will be next weekend before i can work on it.
Expert:  Jay replied 7 months ago.

Ok.. Well even if you rate me, if you have any more questions on this, you can always return back to this question. Follow up questions are no extra charge.

Thanks Jay!