How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris(aka-Moose) Your Own Question
Chris(aka-Moose)
Chris(aka-Moose), Nissan Technician
Category: Nissan
Satisfied Customers: 578
Experience:  16 years of experience
2499435
Type Your Nissan Question Here...
Chris(aka-Moose) is online now
A new question is answered every 9 seconds

I have several tasks to complete on my 3.3L nissan frontier.

Customer Question

I have several tasks to complete on my 3.3L nissan frontier. need help determining order of operation and correct tools
Submitted: 11 months ago.
Category: Nissan
Expert:  Jared D replied 11 months ago.

Hi,

Let me see if I can help. What kind of work are you hoping to perform on your Frontier?

Customer: replied 11 months ago.
currently i'm trying to replace the outter 4x4 bearing. I have a replacement bearing, which matches the original part number, and the bearing is not fitting onto the spindle. Have tried two different brands, and still cannot get the bearing to fit. (LM300849) It's a 2003 Nissan Frontier SC 4x4.
Customer: replied 11 months ago.
Also, I'm having trouble with an oil light that comes on during start up, about 50% of all starts (hot or cold). Engine shudders, oil light flickers for about 2 seconds, then rev the motor, and all is well. Oil has been changed recently, and it always been changed 3-4K miles. 200K on the motor.
Expert:  Jared D replied 11 months ago.

That's odd, can you tell where the bearing is getting hung up? It fits in the hub but not onto the spindle right?

Expert:  Jared D replied 11 months ago.

Which brands have you tried thus far? I show a Timken SET37.

Expert:  Jared D replied 11 months ago.

When it gives you the rough idle on startup have you noticed any smoke or rich smell from the exhaust?