How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask FIXITMAN Your Own Question
FIXITMAN
FIXITMAN, MasterTechnician
Category: Nissan
Satisfied Customers: 17142
Experience:  ASE Master Certified, AA Degree Auto/Diesel Tech
1627031
Type Your Nissan Question Here...
FIXITMAN is online now
A new question is answered every 9 seconds

I have a 02 Nissan Maxima that won't rev past 1500 rpm, like

Customer Question

I have a 02 Nissan Maxima that won't rev past 1500 rpm, like something cuts it, only codes are p1800 and c1130 I need help
Submitted: 9 months ago.
Category: Nissan
Expert:  FIXITMAN replied 9 months ago.

Hello, my name is***** you for the question. Can you tell me if the engine seems to run fine below that rpm?

Customer: replied 9 months ago.
The abs light comes on right when it cuts off
Expert:  FIXITMAN replied 9 months ago.

Thank you. The code you are getting is for the variable air induction system. If the manifold is not adjusting from a bad motor or a manifold failure then the vehicle will run like this.

Customer: replied 9 months ago.
Ok solenoid replaced, code off, mechanism now works, but same issue
Expert:  FIXITMAN replied 9 months ago.

Your other code is for a cam sensor problem. Has that been repaired also?

Customer: replied 9 months ago.
No, c1130 is an abs code code C1130 sets when ecm detects engine fuel cut system has failed
Expert:  FIXITMAN replied 9 months ago.

Sorry for not clarifying. I have had this ABS code come up many times, and for some reason it is typically associated with a cam sensor code. Many generic scan tools will not read this cam code though as it only shows as pending and not a hard code.

Customer: replied 9 months ago.
Ok, replaced both cam sensors, and still same issue, nothing changed
Expert:  FIXITMAN replied 9 months ago.

Does the engine lack power up to that RPM when the vehicle is moving? Does your scan tool read live engine data?

Customer: replied 9 months ago.
I have a snap on verdict, what do you want me to check?
Expert:  FIXITMAN replied 9 months ago.

I would like to know what the crank sensor is reading as well as what the air flow meter reads as you rev the engine.

Customer: replied 9 months ago.
Got it! I realized that the battery voltage rises to 17v and that's when it cuts off,so I loaded the system, turned on everything electrical and got the voltage to around 13v and the car drives fine now!
Customer: replied 9 months ago.
do you think it's a bad alternator?
Expert:  FIXITMAN replied 9 months ago.

If it is overcharging then that will definitely cause this. If it has the wrong battery then this can occur otherwise it is more than likely the alternator itself.