How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask JOHN aka Eauto Your Own Question
JOHN aka Eauto
JOHN aka Eauto, The Car Guy
Category: Nissan
Satisfied Customers: 15577
Experience:  ase tech over 15 years in the field uaw union member
6149662
Type Your Nissan Question Here...
JOHN aka Eauto is online now
A new question is answered every 9 seconds

I have a 05 maxima just installed a rebuild trans filled

Customer Question

I have a 05 maxima just installed a rebuild trans filled with valvoline import multi vehicle test drove for 20 or so mins ran great then left her running for about another 20 min to check fluid levels checked out good got back it and would not pull at all shut it off let it cool would pull then once hot again stopped what's up
Submitted: 1 year ago.
Category: Nissan
Expert:  JOHN aka Eauto replied 1 year ago.

did you flush the cooler?

Customer: replied 1 year ago.
it's a liquid cools trans
Expert:  JOHN aka Eauto replied 1 year ago.

any codes?

Customer: replied 1 year ago.
0 codes 0 lights
Expert:  JOHN aka Eauto replied 1 year ago.

who did the rebuild? sounds lie a internal leak or bypass.. did they give you a warranty?

Customer: replied 1 year ago.
No warranty
Customer: replied 1 year ago.
But was curious as if the tcm needs programmed if that has anything to do with it but if it pulls cold it should pull warm right ???
Expert:  JOHN aka Eauto replied 1 year ago.

you bought a rebuilt unit with no warranty?

Customer: replied 1 year ago.
It's cold now and now it won't pull at all done even feel in engage
Expert:  JOHN aka Eauto replied 1 year ago.

its a internal failure...you bought a bad unit..

Customer: replied 1 year ago.
What about the one I took out it ran fine while cold and once warm it hard shift from 1-2 2-3 and down shift
Customer: replied 1 year ago.
They told me they would give me a refund on trans but argued with me that it was my fault improper install said I probably didn't lock in torque converter
Customer: replied 1 year ago.
I know I did tho
Expert:  JOHN aka Eauto replied 1 year ago.

your original likely had a bad valve body there is a tsb

Customer: replied 1 year ago.
Anything I can try on the new one before I pull it and is there a way to put a new valve body in and test the old before I reinstall sorry to ask so many questions but this trans is so expensive wanna be sure before I drop 3 grand on a complete reman
Expert:  JOHN aka Eauto replied 1 year ago.

no way to test uninstalled

Expert:  JOHN aka Eauto replied 1 year ago.

if the torq converter is locked in there is nothing you can do but remove

Customer: replied 1 year ago.
We'll I'm starting to pull out now I'll get back with you if I have any trouble with new one
Expert:  JOHN aka Eauto replied 1 year ago.

ok

Please remember to only rate my service when you are satisfied. IF you feel the need to rate "Poor Service" or "Bad Service", please stop and reply to me via the REPLY TO EXPERT button with the issue you have. I will be happy to continue further and do everything I can to provide you with the service you seek.

I am not paid unless I get a rating of 3 to 5 Stars/Smiley Faces. If I have helped you with your question, please give me an appropriate rating so that I get credit for helping you

Related Nissan Questions