How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim Mohr Your Own Question
Tim Mohr
Tim Mohr, ASE MASTER TECH
Category: Nissan
Satisfied Customers: 560
Experience:  30 YRS EXPERIENCE, FOREIGN AND DOMESTIC, GAS AND DEISEL
17454363
Type Your Nissan Question Here...
Tim Mohr is online now
A new question is answered every 9 seconds

I have a 94 nissan quest it's always been very reliable, It

Customer Question

I have a 94 nissan quest it's always been very reliable , It starts right away and idles smooth at about 750 rim . It recently started suddenly race up then drop back to nomal idle , it never runs ruff or stalls . But the real problem is while driving it bucks and surges . Right around when I feel the passing gear should kick,in I get a sudden loss power followed by a surge . When the passing gear does engage it bangs like a neutral drop, now I could be wrong but I'm not feeling it's the tranny because that same power loss & surge while I'm in ,park in my driveway.this is affecting the function of the tranny but not a tranny problem in it self . This power loss and surge seem to happen between 2750 and 3200 rpm,s . Oh the over drive light does blink on and off now when engine first starts . ITS SO FRUSTRATING SHE NORMALLY NEVER GIVES ME ANY PROBLEMS, I CANT! AFFORD A NEW CAR I NEED TO SOLVE THIS ! HAVE YOU EVER COME ACROSS THIS PROBLEM..? I've changed the cap &rotor plugs gas filter and Lucas deep clean gas treatment , and cleaned the M,A,F. Sensor even disconnected battery to try and reboot . I'm all out of ideas Please Help Thanks Bill
Submitted: 10 months ago.
Category: Nissan
Expert:  Jay replied 10 months ago.

Hello Bill, my name is ***** ***** thank you for your question.

There could be a few things going on here. First I need to ask some questions to possibly understand everything you are dealing with.

When you get this surging, do you find it does it when going up a hill or under heaver acceleration? But if you lightly accelerate it's ok?

Also when you see this loss of power do you watch the RPMS? and see it fluctuate? or Surge up?

Do you have a Check Engine light on when the van is running also?

Let me know..

Thanks Jay!