How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim's Auto Repair Your Own Question
Tim's Auto Repair
Tim's Auto Repair, mechanic
Category: Nissan
Satisfied Customers: 15638
Experience:  Have owned a repair shop for 25 yrs.
14541291
Type Your Nissan Question Here...
Tim's Auto Repair is online now
A new question is answered every 9 seconds

I have a 2000 frontier with a rl4r01a transmission. After

Customer Question

I have a 2000 frontier with a rl4r01a transmission. After starting the truck If I shift the truck into drive and press the accelerator the engine just revs and the transmission does not engage. I then either have to wait at least 10 min or I can shift it into*****for 1/2 a mile and then shift it into Drive and drive works then. It seems to be worse in the winter time. Reverse works, Drive is the only setting that takes time before engaging.
Submitted: 1 year ago.
Category: Nissan
Expert:  Tim's Auto Repair replied 1 year ago.

Hi, My name is ***** ***** for the delay.

I will do my best to assist you

is the fluid the only thing you repaced?

Customer: replied 1 year ago.
Only replaced Fluid
Expert:  Tim's Auto Repair replied 1 year ago.

from the way you explain the problem,,it sounds as if your filter is clogged

Expert:  Tim's Auto Repair replied 1 year ago.

this is why it must warm up so the fluid will get thin enough to go through the clogged filter

Expert:  Tim's Auto Repair replied 1 year ago.

remove the transmission pan and replace the filter,,i think this will fix your problem,,if not,i would think the problem is internal and not electrical

Expert:  Tim's Auto Repair replied 1 year ago.

thanks

If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feedback ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help.

Customer: replied 1 year ago.
It only does it after truck has been sitting all night long. I wondered that but it only does it in the morning and not the rest of the day, even if the truck sits 9 or 10 hrs. If I remove the pan should I clean any of the solenoids, could they be sticking?
Expert:  Tim's Auto Repair replied 1 year ago.

no,,i dont think it is a soenoid,,i think your filter is clogged

Expert:  Tim's Auto Repair replied 1 year ago.

thanks