How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jay Your Own Question
Jay
Jay, Nissan Technician
Category: Nissan
Satisfied Customers: 19874
Experience:  20+yrs experience with Nissan & Infiniti Trained & Certified.Currently still working for Dealer
10181755
Type Your Nissan Question Here...
Jay is online now
A new question is answered every 9 seconds

I have a 2008 Nissan Altima SL 3.5L. Yesterday, while

Customer Question

I have a 2008 Nissan Altima SL 3.5L. Yesterday, while driving, the car suddenly slowed and then gained back speed however I never took my foot off the accelerator. The "Service Engine Soon" light came on and the loss of acceleration would happen anytime I pushed on the accelerator too fast. I was able to park the car in a safe location. From my previous experience this feels like a transmission issue, but I am not familiar with the CVT transmission. I am fearful to try and drive it to an auto parts store or mechanic for fear of it dying on the road. Any suggestions are greatly appreciated! Thank you.
Submitted: 1 year ago.
Category: Nissan
Expert:  Jay replied 1 year ago.

Hi, My name is*****'m happy to help you. During our conversation, I may be presenting you with different things to try, and ask you some Questions to get a better understand of the issue so I can answer your question properly. So stick with me to the end, and I am sure we should be able to get this issue resolved for you!

This is my first suggestion for your issue. Do you have a Auto Zone near you? As long as your not in California, Auto Zone offers free scans. If you can go there and have them read the codes that has caused the Service Engine Soon light to come on, then return with the codes that would help me to help you better.

When the Service Engine Soon light comes on, that means the computer has detected a fault and generated a code pointing to the system that has the fault. That is why I need the code. For direction.

Do you think you can do this? There is no rush, I can keep this question open till you can do it.

Let me know..

Customer: replied 1 year ago.
I can try, my only concern is the car stalling out while trying to the to the auto parts store. I will respond if I can get the code. thanks
Customer: replied 1 year ago.
here are the codes I received from the diagnostic report at the auto store:C1143 - they could not tell me what this code means
P0826 - manual mode switch
P1217 - engine over temperature condition
Expert:  Jay replied 1 year ago.

Thank you for getting me the codes. Give me a few mins to look them all up and get back to you.

Expert:  Jay replied 1 year ago.

Well I have some of the code info. One code is not a good code.

Did you have a Steering rack done recently?

Customer: replied 1 year ago.
No I have never had work done on the steering, or had issues with the steering. I did have an alignment about a year ago.
Expert:  Jay replied 1 year ago.

Well one of the codes was a Engine Over temp code. Do you recall if the car was over heating when this happened?

Customer: replied 1 year ago.
The temperature light did not turn on, as I recall only the service engine light was on at the time of th eissue, but I do not recall what the temperature gauge was reading.
Expert:  Jay replied 1 year ago.

Based on the one code for the engine over temp, that could certainly cause what you were describing. How did it drive to get the codes checked?

Customer: replied 1 year ago.
It did fine, but it was only 1/2 a mile away and I was very easy on the accelerator.
Expert:  Jay replied 1 year ago.

You do not have a Over temp warning light. You have the gauge.

I would pay close attention to the gauge and have the coolant system checked. It sounds like you may have been over heating and that was causing your issue.

Customer: replied 1 year ago.
ok thanks. I'll take it to a mechanic
Expert:  Jay replied 1 year ago.

Your welcome and thank you for using JustAnswer.com

Don't forget to Rate me if your Satisfied with my help. I hope I have provided you with Excellent Service

Thanks Jay!

Related Nissan Questions