How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris(aka-Moose) Your Own Question
Chris(aka-Moose)
Chris(aka-Moose), Nissan Technician
Category: Nissan
Satisfied Customers: 613
Experience:  16 years of experience
2499435
Type Your Nissan Question Here...
Chris(aka-Moose) is online now
A new question is answered every 9 seconds

Xterra: 2003 Nissan Xterra 2.4 a/c will not kick on!

Customer Question

2003 Nissan Xterra 2.4 a/c will not kick on!
Submitted: 1 year ago.
Category: Nissan
Customer: replied 1 year ago.
all wiring tested good! Intake sensor tested good. The ECU is not supplying a ground when the button is pushed. I can ground the ecu at pin 12 at the computer and the ac works very well. If I jump the pressure switch it does not make a difference. Under normal circumstances I have source voltage at pin 12. I switched out the relay and no luck. I put a new ECU in the vehicle and no luck. What I can not seem to test is the on/off switch for the ac located in the air control head. I have 2 wires in the m95 connector at the control head that do not show on the diagram and I can not find a reference for them. They are pins 4 and 5.
Expert:  Jay replied 1 year ago.
Hi, My name is*****'m happy to help you. During our conversation, I may be presenting you with different things to try, and ask you some Questions to get a better understand of the issue so I can answer your question properly. So stick with me to the end, and I am sure we should be able to get this issue resolved for you! Do you know if the AC system has the proper freon level?
Customer: replied 1 year ago.
yes I added a little detail to what is going on
Expert:  Jay replied 1 year ago.
How did you add freon? Do you have AC Gauges?
Customer: replied 1 year ago.
no the Freon level is good. I do have gauges!
Customer: replied 1 year ago.
I can ground pin 12 in ecu which is a/c relay and the a/c blows ice cubes!
Expert:  Jay replied 1 year ago.
If you ground that, and the AC comes on, what is your pressure readings for the AC system??
Customer: replied 1 year ago.
it was around 40 and 195 ish
Expert:  Jay replied 1 year ago.
What is the outside temperature?
Customer: replied 1 year ago.
when I tested it was about 85 high humidity!
Expert:  Jay replied 1 year ago.
Those readings sound to high. I wonder if you maybe over charged.. Hang on while I pull up my ac chart..
Customer: replied 1 year ago.
ok
Expert:  Jay replied 1 year ago.
Please double check those readings. Your low side pressure seems to high. Your high side sounds ok.. Let me know..
Customer: replied 1 year ago.
even if it is overcharged it should atleast kick on momentarily correct? And, it used to work just fine. Last year replaced a hose and set the charge according to the sticker under the hood think it was a little over a pound!
Expert:  Jay replied 1 year ago.
The AC pressure sensors will keep the AC from coming on if the pressure is to low or to high to protect the system. Please double check the pressure readings..
Customer: replied 1 year ago.
If the system is overcharged and you jump the pressure switch should it engage regardless of charge?
Expert:  Jay replied 1 year ago.
Jumping the pressure switch won't allow the AC to come on. You can jump the AC relay to do that.
Customer: replied 1 year ago.
is the pressure switch done on a 5 volt or a 12 volt reference?
Expert:  Jay replied 1 year ago.
Looks like a 5 volt since it gets power right from the Ecm
Customer: replied 1 year ago.
the low side is getting down to about 30-33
Customer: replied 1 year ago.
checked voltage across the pressure switch and had 4.7 volts when the system was running!
Expert:  Jay replied 1 year ago.
ok.... That is where is should be.. So your pressures are with in spec and so is the pressure sensor.. Where are you jumping the relay exactly? Do you have a Ohm meter?
Customer: replied 1 year ago.
I am grounding at the ecu which is pin 12 and that comes right from the ecu!
Expert:  Jay replied 1 year ago.
You don't have a code for the IAC do you?
Customer: replied 1 year ago.
have any of these air control units failed giving you this problem that you have seen?
Customer: replied 1 year ago.
no codes
Expert:  Jay replied 1 year ago.
Well the IAC has to change the idle speed to accommodate for the load of the AC when on. I am wondering if there is something going on with the IAC and since it can't raise the idle, it won't allow the Ecm to turn on the AC. Another thing. The controller. When you press the AC Button, does it light up? I am wondering if you have a bad AC switch?
Customer: replied 1 year ago.
yes it lights up and of course there is no pinout for the switch testing!
Expert:  Jay replied 1 year ago.
Yes, your right about the switch. I would certainly want to try another switch though. Based on your information. Everything sounds like it should be there to work. By you grounding the circuit at the Ecm, that tells me everything in the wiring is good. You already replaced the Ecm, so it's not that. You have 5 volts from the AC pressure sensor when operating. The only thing I can think of, it maybe it's the switch. I would try to get a used controller and plug it in and try it. That is where I would be going. Also, Check that intake Sensor. See if that is good also. That could play a factor in it's operation and act like a bad Ambient temp sensor.
Expert:  Jay replied 1 year ago.
I take it you have the wiring diagram?
Customer: replied 1 year ago.
yeah I sure do
Customer: replied 1 year ago.
there are 2 wires in the air control unit that are not on the diagram. Pin 4 and 5
Expert:  Jay replied 1 year ago.
Yeah, I saw that you said that. But like you, the wiring diagram does not show that. So that could be the AC switch since the AC switch is not in the diagram. These Ac systems were what I remember, Port installed.
Customer: replied 1 year ago.
port installed?
Expert:  Jay replied 1 year ago.
Yeah, normally when the manual leaves that type of information out. The Port when these trucks were shipped in, installs some of the accessories. Like the AC. For the 02 Altima's to 06 they installed auto dimming mirrors. They do allot of the factory installs. Then the cars are shipped to the dealers.
Customer: replied 1 year ago.
ok I have heard of them doing that never heard it called that
Customer: replied 1 year ago.
do you have any test for the IAC?
Expert:  Jay replied 1 year ago.
The test is done with a scanner. It activates it and you see if you can raise and lower the idle to see if it can do that. If it can, then it's operating. If it can't, then it may not be working properly.
Customer: replied 1 year ago.
Ok I am going to keep this open and order a used control head and ill let you know how it goes!
Expert:  Jay replied 1 year ago.
Ok.. Please do. This one has me interested. I don't get interested that much until there are issues that don't make sense. This doesn't make sense.. Talk to you soon.