How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike V. Your Own Question
Mike V.
Mike V., Nissan Technician
Category: Nissan
Satisfied Customers: 23617
Experience:  Nissan factory trained and Certified Subaru Technician.
Type Your Nissan Question Here...
Mike V. is online now
A new question is answered every 9 seconds

my nissan maxima wont start no spark to coils

This answer was rated:

my nissan maxima won't start no spark to coils
GreetingsCustomerand welcome to JA! I will do my very best to assist you with your problem.
Do you have a test light for checking the circuits?
Customer: replied 6 years ago.
yes and a ohmmeter
Ok, check for power on the red wires on the coils and for continuity to ground on the black wires. Let me know!
Customer: replied 6 years ago.
there is voltage at the coil and there is continuity to ground
Customer: replied 6 years ago.
what elsecan be wrong

A bad cam or crank sensor can cause these issues. Since you have power and ground, that meant the ecm is not telling the coils to fire. If you are sure it is spark that you are lacking and not injector pulse,
i would start by replacing the cam shaft sensor. You can try ohming the sensor and see if it is within spec. Here are the readings.


Customer: replied 6 years ago.
i don't have voltage to the sensors why
It generates the voltage, When the wheel passes by the sensor.AC voltage at 4.2 volts per millisecond. You need a scope to see it, it is to small to pick up with a volt meter or test light.
You should see battery voltage on the red wire to the crank sensor however

Edited by carguy1 on 5/12/2010 at 7:12 PM EST
Customer: replied 6 years ago.
there is no vvoltage to the crank sensor
This is the one on the front of the engine next to the crank pulley, are we on the same sensor? Also, if we are, does the check engine light come on when you turn the key on?
Customer: replied 6 years ago.
we are on the same sensor the service engine light comes on when i turn the switch
You have a break in the red wire. There should be voltage on it.If you turn the key on and the light is coming on, the ecm relay is getting voltage.This wire comes off the ecm relay,so you need to find the break.It might be the entire problem.
Customer: replied 6 years ago.
where is the ecm relay located and can you reccomand a good manual for this vehicle
It is under the hood in front of the battery. Wires go bad here all the time because of the battery acid. Here is a diagram.
I would suggest a subscription to
You can get a subscription for just your car fairly inexpensively.
Mike V. and 2 other Nissan Specialists are ready to help you