How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Smogfather Your Own Question
Smogfather, ASE Certified Technician
Category: Nissan
Satisfied Customers: 117
Experience:  Master ASE
Type Your Nissan Question Here...
Smogfather is online now
A new question is answered every 9 seconds

My car turns over but wont start i smell gas..RPM..stall..injector

Customer Question

Sometimes my car turns over but wont start i smell gas but i am getting spark to the plugs. When it does start it runs good for a little bit then the RPM's start to jump up and down and sometimes stall the last computer diagnosis i had said it was fouled injector which i replaced but also detenation failure and bad oxygen sensor
Submitted: 6 years ago.
Category: Nissan
Expert:  Smogfather replied 6 years ago.
Hello and welcome to Just Answer! Do you get black smoke out the tail pipe? If you do then replacing the 02 sensor is a could Idea. Is the check engine lite on? Check the condition of the injector connecter terminals, are they green inside? scrape off the green stuff. Check your intake duct ( the rubber thing that connects the throttle body to the Mass Air flow meter. I bet it is torn. If that rubber piece has any tears or other leaks your car will not run well at slow engine speeds. My name is XXXXX XXXXX I am here to help. Please click ACCEPT as that is the only way I am paid for this job. Any further posts will be directed to me.
Smogfather and 3 other Nissan Specialists are ready to help you
Customer: replied 6 years ago.
I dont get black smoke but yes the engine light is on and the reading says the left O2 sensor is fouled. I was creeping along in traffic and all of a sudden it just stalled after trying to statrt it a few times it finally fired back up. It ran okay for a few days then I went out one morning to start it and it wouldn't start I replaced an ignition module and it worked one time and the next time I shut it off it wouldnt start. I put the old ignition module back on and it fired up but still tends to run a little choppy from time to time
Expert:  Smogfather replied 6 years ago.
Describe 'choppy' as throughly as possible
Customer: replied 6 years ago.
It will be running smoothe and all of a sudden the tach will jump up and down and almost stall and i will have to pump the throttle to keep it going. Also i just went outside to check out the few suggestions you gave when i was out there it fired up and chugged a little bit and then smoothed out so i looked under the hood for air leaks in the gaskets and any bad connections. I bumped into a main harness that holds the wires for the injectors and plug coils and the clutch fan came on and the car wanted to sputter so i pushed the harness back where it was and the fans shut off and the car smoothed out again. What are the chances of an electrical short?
Expert:  Smogfather replied 6 years ago.
As I stated before, the electrical connectors on your car are known for oxidation. I said green stuff, but that is whaIt it is. If the fan came on, the oxidation or other open circuit condition is likely coming from your coolant temp. sensor connector. Are your motor mounts bad? This will cause your engine to move excessively and that will tug on your wiring harness. If you get your engine to idle smoothly you can try tapping lightly on the Mas Air Flow meter. If you get a corresponding change in the way the engine runs, You have a bad MAF. Please click ACCEPT if this helps you any Thank you Robert

Related Nissan Questions