How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike V. Your Own Question
Mike V.
Mike V., Nissan Technician
Category: Nissan
Satisfied Customers: 23639
Experience:  Nissan factory trained and Certified Subaru Technician.
Type Your Nissan Question Here...
Mike V. is online now
A new question is answered every 9 seconds

1997 Sentra GXE: restart..gallon..there was a noise coming..sounded

Customer Question

1997 Sentra GXE, last night it sputtered to a stop and would not restart, 1/4 tank of gas, added another gallon and the engine would not turn over. Left it at the store and walked home went to car 15 hours later it started but it sound really rough when it started and there was a noise coming from the area of the alternator that sounded like rocks was able to get it home. Could this be a bad alternator, fuel pump or something else?
Submitted: 6 years ago.
Category: Nissan
Expert:  Mike V. replied 6 years ago.
Hi there!this sounds like a possible timing chain issue. You need to remove the belts from the alternator and power steering. Then start the car and see if the noise still exists.If it does then it is likely the timing chain, if not, spin all the pulleys by hand and see if one is binding up. if the timing chain or tensions have a problem the car could stall on you and not re fire.Hope this helps!
Customer: replied 6 years ago.
timing chain is not the issue, car runs rough after timing chain was checked. car is still running a touch rough and stalling at low rpm at light, or parked or in neutral. changed spark plugs is the other thing that changed.
Expert:  Mike V. replied 6 years ago.
so what is making the noise that sounds like rocks? Did you remove the drive belts as instructed?
Customer: replied 6 years ago.
doesn't sound like rocks, more metallic the rock sound went away mysteriously.... did not remove the belts. I did replace upper tensioner as the plastic was broken.. but the car stalled at a stop and wouldn't restart. now it stalls when warm at stop in park/neutral or drive
Expert:  Mike V. replied 6 years ago.
OK, is the check engine light coming on? Do you mean the timing chain tensioner was broken?
Customer: replied 6 years ago.
no check engine light. the plastic on the upper was broken which was replace but did not resolve the stalling that caused the problem
Expert:  Mike V. replied 6 years ago.
OK. chances are if it was broken it most likely jumped time. If the timing chain was not reset you can have this problem. I suggest checking the timing using a timing light.
Also, you can try cleaning the IAC-AAC valve. Sometimes they get full of carbon and the car won't idle. HERE is a diagram of it's location. Clean it up with some carb cleaner and reinstall it.
Customer: replied 6 years ago.
had p0400 code, found bad hose on egr, replaced that. replaced plugs, cap and rotor. replaced fuel filter. still stalls when warm and won't restart until it is totally cold
Expert:  Mike V. replied 6 years ago.
Well,I would say at this point it is either a problem with the IAC or with the engine coolant temp sensor.
Customer: replied 6 years ago.
problem was bad alternator.... it was replaced and problem resolved.
Expert:  Mike V. replied 6 years ago.

I think you may have found that in the first post when I said to remove all of the drive belts and see if the noise went away.

I am glad to hear you got it fixed and it is back to running good for you!