How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim West Your Own Question
Tim West
Tim West, ASE Certified Technician
Category: Nissan
Satisfied Customers: 4638
Experience:  Just Answer Car Expert ASE Certified Service Manager
9949505
Type Your Nissan Question Here...
Tim West is online now
A new question is answered every 9 seconds

I have a 98 Nissan Frontier 4x4 2.4L 5 peed the truck is running

Customer Question

I have a 98 Nissan Frontier 4x4 2.4L 5 peed the truck is running bad sometimes, and dieing when it gets to or running reel rough. Now it starts missing sometimes and then dies, it will start back up and kill imidiatly after. Got any suggestions. Codes P0500, P0100, P0110, P0110pd
Submitted: 7 years ago.
Category: Nissan
Expert:  Tim West replied 7 years ago.
Thanks for visiting JA.com
Sounds like for one, the mass air flow sensor is bad. Try unplugging the mass air flow sensor first. Let me know if this changes the problem of the vehicle.
The mass air flow sensor is located on the hose coming out of the air filter box.
Also check the hose for damage or leaks. Also check the air filter box, make sure it's closed tight.

The p0500 code is a code that deals with the speedometer. Is the speedometer working properly?


Let me know.
Customer: replied 7 years ago.
Hey i pulled the breather off there are two hoses one big going to the valve cover and a vacuum line in the back of it that goes to a t in the line
Expert:  Tim West replied 7 years ago.
how did it look?
Customer: replied 7 years ago.
where the hose comes off of the breather it goes to a t which goes to the throttle body and the other way it goes to a deal that looks like three sensors together and the top one says boost sensor the one that passes the throttle body goes to a sensor on the intake do u no where it would b located
Expert:  Tim West replied 7 years ago.
graphic
Customer: replied 7 years ago.
ok i disconnected it and its idling out side like i said though it runs sometimes and sometimes real bad and now when it dies when ur driving and go back to idle it kills when it starts back up it kills right away until u let it sit for a few minutes and when it does crank up it stays running and misses real bad for a few minutes and smokes black with a heavy black smoke
Expert:  Tim West replied 7 years ago.
But right now, the vehicle is idling ok?
Customer: replied 7 years ago.
its idling up and down a little bit but its still running usually it just dies like u turned the key off lol its got a mind of its own
Expert:  Tim West replied 7 years ago.
Okay, no problem. The mass air flow sensor is bad. This could be the cause of all the codes. It might also have a problem with the air temperature sensor. I would replace the mass air flow sensor clear the codes and recheck.
To verify,get the vehicle acting up really badly and disconnect the mass air flow sensor. If the problem gets better, I would feel safe about replacing the sensor.
1. Check the Mass Air Flow Sensor output voltage on the Red wire at the Mass Air Flow Sensor to see if it matches the scan tool voltage reading and see if it goes to 0 volts like the scan tool shows.

2. If the Mass Air Flow Sensor output voltage drops to 0 volts on the Red wire, make sure there is still good battery voltage to the Mass Air Flow Sensor on the Black/Pink wire.

3. Make sure the Mass Air Flow Sensor Red wire is not grounding in the harness.


Customer: replied 7 years ago.
thanks man i appriciate the help
Expert:  Tim West replied 7 years ago.
No problem, I will be here even after you click accept incase you have any other questions.
Tim West and 3 other Nissan Specialists are ready to help you
Customer: replied 7 years ago.
hey i just went press the gas with the mass air flow unpluged and it wont take any fuel it runs like shit
Customer: replied 7 years ago.
hey i tryed to give it some gas with the sensor unplugged and it wont take anyfuel it runs horrible and smells flooded
Expert:  Tim West replied 7 years ago.
Yea, you should replace that sensor asap.
Customer: replied 7 years ago.
u think thats whats making it do all this crazy shit
Expert:  Tim West replied 7 years ago.
Yes. Not to mention the code verifies it.
Customer: replied 7 years ago.

alright my man i appreciate your time for the chat auto zone is the only parts store that can get it and its almost 500 bucks lol besides going to a dealer which more than likely cost more

 

Expert:  Tim West replied 7 years ago.
Well, you can remove the mass air flow sensor and clean it. See if this changes it.
You need to buy some special cleaner for the sensor. Anything too harsh could damage the wiring.
Customer: replied 7 years ago.
i ordered one online for it a whole lot cheaper
Expert:  Tim West replied 7 years ago.
Great.
Customer: replied 7 years ago.
hey i pushed accept, it didnt go through to u if not let me no, thanx
Expert:  Tim West replied 7 years ago.
It went through thanks again.

Related Nissan Questions