How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chad Farhat Your Own Question
Chad Farhat
Chad Farhat, ASE Certified Technician A6 - Electrical / Electronic systems A7 Heating / Air conditioning systems
Category: Infiniti
Satisfied Customers: 3262
Experience:  Owner at Carolina auto Service & Sales , 20 years Experience in Foreign & Domestic vehicle
45790705
Type Your Infiniti Question Here...
Chad Farhat is online now
A new question is answered every 9 seconds

I have a 2005 Nissan armada and the battery keeps dying I

This answer was rated:

I have a 2005 Nissan armada and the battery keeps dying I noticed the lights external lights stay on for about 5-10min before they shut off. when measuring my current draw in pulling 4A until the lights turn off then will drop to 1A I isolated to fuse 19 in the pass fuse box when I pull that fuse it drops to about 40mA.
Customer: replied 8 months ago.
this is what I done I unplugged the transmission, cluster, climate control, & ABS unit still have that draw. I know there's a lot of things on this cuircuit

Hi, I'm Chad. Welcome to JustAnswer. I'm reviewing your question and I will be posting your reply ASAP.

Customer: replied 8 months ago.
ok thanks

hey how are you

when you unplugged these parts ,did the draw go down

Customer: replied 8 months ago.
nothing dramatic

where all fuses tested for drain when you went across all of them

have you taken out the passenger fuse box where that fuse is located and checked the back of it for any wires touching

alternator checked for open diode ,drain battery down

is the battery been tested with load on it

have you unplugged all the parts that fuse # 19 control

is there any issues in the truck at this time

and is there any prior work that could have contributed to this

Customer: replied 8 months ago.
I unplugged the altinator and no change & I have not remove the fuse box
Customer: replied 8 months ago.
also the only components I unplugged were the ones I mentioned earlier

this a tough one , you will have to trace back , wish i had an exact answer for you but with battery drainage testing will be needed

I wil test all the wires that fuse #19 controls , i know it is easier said then done

Hey how are you

sI was checking to see what you find out and did you take fuse box out

Chad

Customer: replied 8 months ago.
I'll be doing that today if the vehicle is there I think there an issue with the title and there taking it back to the auction as I was just informed but thanks anyway for your help

you welcome

yes don;t buy if no title :)

Let me know if you need anything else on it , just reply back here & we can continue.

if you are good , Please Kindly rate me.

Hope I was helpful to you

A 5 Star Positive Rating is Much Apreciated

This Post Will Stay Open for You To Come back and Ask me Any Follow Up Question You May have on this issue , even after you rate me

Thank You

Chad Farhat
ASE Certified Tedchnician

Chad Farhat and 2 other Infiniti Specialists are ready to help you

Related Infiniti Questions