How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jay Your Own Question
Jay
Jay, Certified Infiniti Technician
Category: Infiniti
Satisfied Customers: 18693
Experience:  20+years, Nissan and Infiniti experience and currently now working for a Infiniti Dealer
10181755
Type Your Infiniti Question Here...
Jay is online now
A new question is answered every 9 seconds

2009 infiniti G37 when I disconect the right side cam sensor

Customer Question

2009 infiniti G37 when I disconect the right side cam sensor the car runs and when I connect it back it runs it gives me this code p0340
Submitted: 2 months ago.
Category: Infiniti
Expert:  Jay replied 2 months ago.

Hello my name is ***** ***** thank you for your question.

This is actually a old trick we do to determine what I may suggest. But before I open my mouth, let me make sure of a few things.

With both cam sensors plugged in, the car will not run correct? It will only run when the cam sensor is unplugged? Has any sensors been replaced?

Customer: replied 2 months ago.
the right side
Expert:  Jay replied 2 months ago.

That is what I was afraid of. Ok, this is normally a indication the engine has jumped time. It's 2 teeth off. So the timing chain would need to be reset. Once reset, then you need to turn the engine over with the fuel system disabled to ensure that the tensioners build pressure before you start it.

Do you have any more questions on this?

Related Infiniti Questions