How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jay Your Own Question
Jay, Certified Infiniti Technician
Category: Infiniti
Satisfied Customers: 18545
Experience:  20+years, Nissan and Infiniti experience and currently now working for a Infiniti Dealer
Type Your Infiniti Question Here...
Jay is online now
A new question is answered every 9 seconds

Stalls with no warning...only occasionally. slows down to a

Customer Question

stalls with no warning...only occasionally. slows down to a stop the engine keeps running. Seems to be on the same stretch of road every time...weird. Ok after re-start.
JA: Is the check engine light on? Does the car stall at idle or when driving?
Customer: When driving only...actually when my daughter is driving. Car is new to me but has happened 4 times in about a thousand miles. The check engine light did come on once had it serviced and they said the code was for the mass air sensor
JA: What is the model/year of your Infiniti?
Customer: 2009 g-37 coupe 70 k miles
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Nothing fuel. Possibly fix myself buy probably better take it in if it throws another code.
JA: Anything else you think the mechanic should know?
Customer: Just got the car...daughter drives it and it hasnt happened when I drive it. Seems to happen when she gets close to home on the same mile of roadway.
Submitted: 2 months ago.
Category: Infiniti
Expert:  Jay replied 2 months ago.

Hello my name is ***** ***** thank you for your question.

Do you have a Service Engine Soon light on when the car is running?

Customer: replied 2 months ago.
It did after the 3rd stall. Had it serviced and they said it was the mass air flow sensor code.
Expert:  Jay replied 2 months ago.

Thank you for that information. Do you have a K&N air filter or cold air intakes?

Customer: replied 2 months ago.
They reset the light but it has stalled again. It is after It is warm and at 50 mph or so. Usually she has been driving for 5 to ten miles before it happens on her way home. It loses power and she has to pull over after a minute or so it is fine again. I bought the car in Nebraska and drove it 400miles home with no problems.
Customer: replied 2 months ago.
I think it is all stock with two mass air sensors
Expert:  Jay replied 2 months ago.

Where is home? Also Do you have a K&N air filter or cold air intakes?

Customer: replied 2 months ago.
Lasalle Colorado. I will check when she gets home later today. Will they have the kn logo on them?
Customer: replied 2 months ago.
Here is a couple pics .
Expert:  Jay replied 2 months ago.

Thank you.. How handy are you?

Customer: replied 1 month ago.
Owned, worked in and ran my own body shop for over 20 years. ..not really a tech guy but can usually get my way through it.
Expert:  Jay replied 1 month ago.

This is most likely due to a bad MAF sensor. But what I would do first is get a can of MAF sensor cleaner and try cleaning them first. If that doesn't work, then they will need to be replaced. If it does work, then your good to go!

Do you have any more questions on this?

Customer: replied 1 month ago.
I thought they look sealed from the pics but I can give it a try. It looks like they come off easily with either a phillips or approx 8mm. I found new after market ones on e-bay for under $20 each. If the cleaner doesn't work are these any good at all? Also, would a bad one cause the car to vibrate before it shuts down? Is there any way to tell which one is the problem? Thank You !!
Expert:  Jay replied 1 month ago.

Stay away from after market.. They never work right..

Once you remove the MAF sensors, the heated element is exposed to clean. Before cleaning take a good look at them. If there is any type of dirt in there, it can certainly affect it's operation. So you want to try the MAF sensor cleaner first before replacing.

Customer: replied 10 days ago.
I took the mass air sensors out and cleaned the but a week later the car stalled again. I ordered and installed new ones and it did the same thing. A few weeks later it did it again and I was in the car. I put it in neutral and it would only rev to about 2200 rpm. The slip and vtc light came on. The car ran fine again after the restart. I took it to a mechanic the next day and the codes shown were P010B, P075 AND C1130. They have no idea on how to fix it. We are now driving it with the VTC switched off. Any thoughts?
Customer: replied 10 days ago.
I did have the brakes checked and they are ok. It seems to happen at 40-50mph, at cruising speed, not under braking or acceleration.
Expert:  Jay replied 10 days ago.

Do you have the fuel trim checked ?

Customer: replied 10 days ago.
What is fuel trim?
Expert:  Jay replied 10 days ago.

That is the measurement of air and fuel. It should be a 50/50 mixture. But you need a scanner to monitor that.

Let me know.

Customer: replied 4 days ago.
Hi Jay, It done it a couple times again. Do I need to take it to a Nissan or an Infinity dealer instead of a local mechanic shop? The closest Infinity dealer is about 50 miles away but a Nissan dealer is only about 10 miles away if they would have the right diagnostic equipment. Thanks, Dave
Expert:  Jay replied 4 days ago.

A Nissan dealer should be able to figure this out. The 370z is more or less the exact same drive line.

But if it's stalling, it's of course a safety issue. So you want to address this the best as you can.

Expert:  Jay replied 4 days ago.

If you go to a local shop, they would use after market parts, which these cars done like. They never work right. So you want to stick with OEM parts. Especially electrical parts.

Customer: replied 3 days ago.
Hi Jay, I stopped by the mechanic shop and they checked and the same codes came up...P010B MAF CIRC B2, P0725ENGINE SPEED SIGNAL, CII30 ENGINE/FUEL OUT SYS FAULT AND C1109 BATT VOLT OUT OF RANGE. We changed the mass air sensors from right to left after the last light came on but the code is still the same. They also checked the fuel trim and it was in range. Any ideas now?
Expert:  Jay replied 3 days ago.

When I see a Engine Speed signal code, that is normally due to a Cam Sensor. So you may need to replace both of them. The you may have to replace MAF sensors as well. I see you have those codes.

Do you have cold air intakes on the car or K&N air filters?

Customer: replied 3 days ago.
No and I have replaced the mass air sensors.
Expert:  Jay replied 3 days ago.

Did you replace them with MAF sensors from the dealer?

Customer: replied 3 days ago.
I installed used ones
Expert:  Jay replied 3 days ago.

I do know there is a reprogram for these codes also. So you may simply need the reprogram for the MAF sensor codes

Customer: replied 3 days ago.
I'll take it in to the dealer. Thank you
Expert:  Jay replied 3 days ago.

Your welcome and thank you for using

Don't forget to Rate me if your Satisfied with my help. I hope I have provided you with Excellent Service

Thanks Jay!

Related Infiniti Questions