How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jay Your Own Question
Jay
Jay, Certified Infiniti Technician
Category: Infiniti
Satisfied Customers: 18722
Experience:  20+years, Nissan and Infiniti experience and currently now working for a Infiniti Dealer
10181755
Type Your Infiniti Question Here...
Jay is online now
A new question is answered every 9 seconds

2001 infiniti I 30 no speedo have changed the vss checked

Customer Question

2001 infiniti I 30 no speedo have changed the vss checked +&- at plug ok need pin numbers at ecm to check input to ecm and out put to speedo have code po500. also no cruise. Where can I find the wiring for this?
Submitted: 3 months ago.
Category: Infiniti
Expert:  Jay replied 3 months ago.

Hello my name is ***** ***** thank you for your question.

Do you still need the Ecm terminal layout to do a pin test at the Ecm? I can also supply you with the diagnostic steps for the P0500.

Let me know..

Customer: replied 3 months ago.
Please
Expert:  Jay replied 3 months ago.

ok, Hang on please..

Expert:  Jay replied 3 months ago.

If you have any more questions on this, please feel free to ask.

If not, and you're satisfied with my help, please Rate me. That is how I get credit for my work. I hope I have provided you with Excellent Service.

Thanks Jay!

Expert:  Jay replied 3 months ago.

Oh I gave you the harness layout also.

Customer: replied 3 months ago.
Looks good, hope this get me to the problem of the speedo. Thank You.
Expert:  Jay replied 3 months ago.

Your welcome,

Thanks Jay!

Customer: replied 3 months ago.
Jay still have the same problem. Check all connections for continuity and for shorts and grounds. My vss has 3 wires this shows 2. I have a black red and a white with black. Not a gear try sensor. Red wire is + and black is ground I get a voltage out of the white and black wire when rotating the wheel. Where does the white and black wire go. Again this is a 2001 Infiniti I 30.I don't get a signal out of ecm on pin 86. What am I doing wrong.
Customer: replied 3 months ago.
Let me know asap if you receiver this. Thank You
Expert:  Jay replied 3 months ago.

Did you follow the diagnostic steps I provided for you?

Customer: replied 3 months ago.
Jay did that.Everything check ok. e81 to m15 I think is where the white and black wire is coming in from the vss can't find where it goes to the speedo what pin I think this is the pulse from the vss. I'm I wrong?I think it should come out of the speedo on pin 32 to 86 on the ecm. Not showing a thing there. Thanks again!
Expert:  Jay replied 3 months ago.

Your not getting any wave signal at pin 86 at the Ecm?

Customer: replied 3 months ago.
Right. Not a thing. Should that come from the speedo? I still don't think i'm getting anything to the speedo or its not coming out of it. Maybe bad speedo. Do you have anything that shows the pin in from the vss. Pin number.and plug number. I'm getting back into it tomorrow. Thanks again. Sorry for all the trouble. Darel Jones in Lagrange Ga.
Expert:  Jay replied 3 months ago.

Where did you get the speed sensor you installed?

Customer: replied 3 months ago.
From Bumper to Bumper it's just like the one I toke out. I also checked the trans to see if it had a gear in it for a gear try vss . It didn't not. On the white wire at the vss I get a pulse when turning the tire. Where does it go? Looks to me to go to connector m15 to e81 vss to combination meter. Looking for at the meter. Can you tell me witch plug and what pin?
Customer: replied 3 months ago.
Jay does the white pulse go to the abs? Has to go somewhere. m15 to e81 go to abs. The black wire from the sensor to the tcm and the ecm are grounds. Pin 32 at speedo to 86 at ecm has 4.5 volts from speedo when running no change in gear. What am I missing?
Customer: replied 3 months ago.
Jay white wire from vss goes to abs found that. Where from there. Do you have anything that shows the abs connector pin and where they go. Something from abs plug to speedo connectors. By now you think I'm a ###.
Expert:  Jay replied 3 months ago.

White wire? did you check the speed sensor? I know if the Plastic gear is not the same color or the same size it won't active the speed sensor. Can you try using your old gear on the new sensor?

Customer: replied 3 months ago.
Jay this 2001 infiniti I 30 don't have a gear. It's one like a cam sensor or crank sensor. No gear and I do get a pulse from the white wire when moving the tire. I get 4.5 volts at ecm pin86 4.5 at pin 32, ground at 42 at tcm ground at 58 at the ecm. ABS shows pin 11 to 14 speedo, 11 goes to 13 on the combination I get 4.5 volts there. Still lost!
Expert:  Jay replied 3 months ago.

You have the speed sensor in the trans with the gear!

Customer: replied 3 months ago.
This car VSS does not have a gear try. No gear.
Expert:  Jay replied 3 months ago.

Can you take a picture of the top of the trans towards the back fire wall area and I will try to point it out to you. 2002 when they added the 3.5 they did away with the sensor on the trans. So you should have one.

Expert:  Jay replied 2 months ago.

Still waiting on that picture...

Expert:  Jay replied 1 month ago.

Checking in to see how you made out. let me know..