How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Infiniti
Satisfied Customers: 21601
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your Infiniti Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I have replaced the balancer,the bulb and the fuse on my 09

Customer Question

I have replaced the balancer,the bulb and the fuse on my 09 qx56 passages side and the light still will not come on what do l do .
Submitted: 5 months ago.
Category: Infiniti
Expert:  sprinkles08 replied 5 months ago.

Hello and welcome to JustAnswer!

You may have a few things going on. The problem may be wiring or an internal issue in the fuse box.

Does the right high beam work or have you lost both high and low beam?
Does fuse 41 have power with the low beams on?

Customer: replied 5 months ago.
the right side works on low beam both work on high beam both siginal lights works its just the low beam not coming on left side and I have did everything check the circuit good change the fuse the bulb and balancer just don t know anymore just might have to take it to the dealership
Expert:  sprinkles08 replied 5 months ago.

Something has been lost in testing if the bulb and ballast have been replaced and you believe all wiring has been tested. Possible causes for the light not working are the bulb, ballast or a loss of power or ground.