How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jay Your Own Question
Jay
Jay, Certified Infiniti Technician
Category: Infiniti
Satisfied Customers: 3437
Experience:  20+years, Nissan and Infiniti experience and currently now working for a Infiniti Dealer
10181755
Type Your Infiniti Question Here...
Jay is online now
A new question is answered every 9 seconds

Where is the ECU ground wire in an infinity G35 located?

Customer Question

where is the ECU ground wire in an infinity G35 located?
Submitted: 9 months ago.
Category: Infiniti
Expert:  Jay replied 9 months ago.

Hello my name is ***** ***** thank you for your question.

There is a ton of ground wires. What is your issue?

Customer: replied 9 months ago.
Hello Jay.. I finally got to actually get to ask you personally my question (took me 3 attempts).I have a no start condition. I have changed both cam sensors, crankshaft sensors, IPDM box, Fuel pump and 2 vacuum switch solenoids. I currently have a MAS on order and a knock sensor. I've changed all these after reading what other owners did in the same situation. Also, the ECU is not throwing any codes.I have cleaned and tighten all the grounds that i have been able to find. I have been advised that it could be the ground for my ECU (or one of the control units)Also, my security light comes OFF when the key is in the on position. Sometimes the car will start for like a second (sounds like 2 revolutions) and cuts off
Expert:  Jay replied 9 months ago.

Thank you for all that information. Glad you finally got to speak with me. Don't know why you had a hard time. I would like to know that after we determine direct on your car.

When you changed the Cam Sensors, is it because you had a code for them?

Customer: replied 9 months ago.
No i had no codes whatsoever. On one of the G35 forums, it was stated that the Cam and crank sensors can be bad without throwing any codes.
Expert:  Jay replied 9 months ago.

That is more common from after market sensors. Meaning sensors you buy from auto parts store. Do you have the old sensors? I can tell you if they are after market or not.

Let me know.

Customer: replied 9 months ago.
Basically, the car was working fine... just before i parked up one day going to work i felt it idling differently, the car trembled for a few seconds but it didn't cut out. When i tried starting to leave work.. Nothing.No i've never changed any sensors on my car until now. But i purchased the new ones directly from the manufacturer
Customer: replied 9 months ago.
Sorry, Yes i still have the old sensors
Expert:  Jay replied 9 months ago.

https://dl.dropboxusercontent.com/u/105565483/Cam%20Sensor%20OEM.jpg

If the sensors have this logo on them, They are OEM. Let me know if your old ones have this logo, I am sure the new ones don't.

I have a couple things we can try after you get back to me on this.

Customer: replied 9 months ago.
Just checked... All 3 have that symbol
Expert:  Jay replied 9 months ago.

If you did not have a CAM sensor code, I would want you to re-install them.

In the mean time, Lets try some things. First I take you are handy? If you are handy, try taking the air intake duct off and I want you to snap the throttle plate. Do not clean the throttle chamber. But do take note on how dirty it is as we may need to clean it later. After you snap the throttle plate, put the intake duct back on and see if it starts. Also take note if it felt stuck at all.

Let me know what happens.

Customer: replied 9 months ago.
take the new ones out and put the old ones back in? lol Ok, i will do that first thing in the morning (it's 10:55pm)I had cleaned the throttle body about 2 months before this happened. Not sure if that's an issue.When you say snap the throttle plate, do i use my finger and fully open it and let it go?I also tried starting it with the intake duck off (in case there was some sort of restriction) and i realised that the butterfly on opened (and closed quickly) when i switch the key from ON to OFF. It didn't open when it was held in the START position. Is this normal?
Customer: replied 9 months ago.
the butterfly opened* (and closed quickly)**
Expert:  Jay replied 9 months ago.

Yeah.. That is what I meant. After you cleaned it did you do a Idle Relearn?

Do you have a Code Reader?

Customer: replied 9 months ago.
I can't say that it was done properly as the steps are all timed. But i think it was done correctly as initially the idle was high when i fitted it back together. I have the "bluedriver" but that seems to only work if the car is running. I can get a Launch to borrow.
Expert:  Jay replied 9 months ago.

Sorry for the delay.. Site is having issues.

I will be online most of the day tomorrow if you want to touch base with me tomorrow after you get the original sensors back in.

Customer: replied 9 months ago.
Tomorrow then....I will also do the butterfly snap. should i get a code reader?
Expert:  Jay replied 9 months ago.

Ok..

If you could, that would be helpful

Customer: replied 9 months ago.
Jay, I've managed to swap all sensors back to the old ones. On examination, the new ones also have the logo shown earlier.I've snapped the butterfly in the throttle body although the return was not exactly a "snap.What's the next step?
Expert:  Jay replied 9 months ago.

code reader?

Customer: replied 9 months ago.
Sorry, i had a manic day. I was unable to pick up the code reader. I will have it dropped off tonight or early in the morning.
Expert:  Jay replied 9 months ago.

ok

Customer: replied 9 months ago.
Jay, good day. I was unable to get a scanner to use. However my friend who is a local Nissan mechanic came over and scanned the car. No Engine trouble codes came up. He suggested that the NATS may need reprogramming but after doing a NATS scan.. again, it was trouble free. He checked for an RPM reading and sensor readings (while continuously cranking the car)
Customer: replied 9 months ago.
He said everything seemed fined according to the diadnotics.What now?
Customer: replied 9 months ago.
diagnostics*
Expert:  Jay replied 9 months ago.

When you turn the key to the On position, is the security light ON solid by the clock?

Customer: replied 9 months ago.
It's out.. There is no light. I will do it again now to triple check
Expert:  Jay replied 9 months ago.

ok

Customer: replied 9 months ago.
I armed the system from outside.. waited for approximately 30 seconds for the light to start blinking. When i disarmed the system (opened the car using the keys) the light went out completely (not blinking anymore)
Expert:  Jay replied 9 months ago.

What is the status of the security light when the key is turned to the ON position? That is what I am asking. Is the light on or off?

Customer: replied 9 months ago.
It's off.
Expert:  Jay replied 9 months ago.

https://dl.dropboxusercontent.com/u/105565483/Cam%20Sensor%20OEM.jpg

This is the cam sensor. We need to see if your cam sensors have this logo on them.

Please check and let me know..

Customer: replied 9 months ago.
that logo is present on the 2 cam sensors and the crank sensor, remember we check those a few days ago and you instructed me to put the old ones back in.
Expert:  Jay replied 9 months ago.

oh.. ok...

Can you give me some history on the cars issue? Like how long ago this started, and how did it first develop?

Customer: replied 9 months ago.
The car has been maintained as per Nissan recommendations, It is serviced (oil/filters/plugs) every 3 months irrespective of usage/Mileage. In short i spare no expense. The car has been trouble free throughout.One day when i was driving into the parking lot, the car idled heavily (as though it was suffocating due to lack of fuel/air). It did not cut out. I assumed that my air filter was dirty. I parked as normal without any further issues. After work, the car just will not start... This was the beginning of my troubleshooting (change of fuel pump/filters, sensors).The car did not have any performance issues before this apart from a lag (car will take a few seconds actually propel hard when accelerator was floored)
Expert:  Jay replied 9 months ago.

It never produced any codes after it stalled that time?

Customer: replied 9 months ago.
On one of the scanner used it showed a "00 Initial start" code. A transmission code came up also but i cannot remember what it was. I was assured that an issue with the transmission would not cause a no start issue
Expert:  Jay replied 9 months ago.

Oh, hell yeah a trans can cause a no start issue. I had a Brand New QX56 with 10 miles on it stuck at the lot that was jump started backwards and blew out the a circuit in the TCM which took 2 months to figure out with engineers and Specialists coming to help.

The 00 tells me your not using a full blown scanner to look at your car. You are going to need a full blown scanner to scan the engine system and transmission to see if there is codes there.

Customer: replied 9 months ago.
you are right, the scanner that produced the 00 code was a pocket scanner. My friend used a proper scanner Today that revealed no codes. He didn't scan the transmission.. He checked the engine and the NATS.So should i get the transmission scanned and we'll look to see it there is a code that will actually cause a no start issue?ALSO... For some reason, when i checked my transmission oil level, it's telling me that's it over full... BUT.. I check this weekly (before the no start issue) and the level has always been perfect. Any ideas on that?I mentioned the 00 code to a previous just answer tech who simply told me "i do not know what that means" SMHAnyway, what's your suggestion on the way forward?
Expert:  Jay replied 9 months ago.

Yes, we need to scan the transmission and I would scan all control units to be sure.

a 00 code is not a good code, it's a different language..lol.. Codes for your year car should start with a Letter, and then 4 numbers. Like P0420 which is for a Catt Converter. That is just a example of what a code should look like. If you cleared that 00 code that could have helped determine what real code you may have had with another scan tool. That code may have helped determine the problem as well.

But lets see what happens when you get the rest of the car scanned. I would scan BCM, ABS, and Transmission

Customer: replied 9 months ago.
The ABS? Lol. I didn't see that one coming.
Do you think it's safe to drain the transmission until the fluid level revert to the normal Full line?I will try to get that scan done ASAP! hopefully in the morning
Expert:  Jay replied 9 months ago.

You can't check the trans fluid level if it doesn't run. The transmission fluid level is checked with the engine running. So we need to get the car running first.

Customer: replied 9 months ago.
lol.. okay... Didn't know that ^^^ Thanks again, i'll get back to you tomorrow
Expert:  Jay replied 9 months ago.

you got it. Talk to you tomorrow.

Customer: replied 9 months ago.
Jay, It's been a few days. Apologies.. To be honest i'v been frustrated. there are no codes on the transmission and the BCM seems to be ok. I say seem because we don't know of a "safe" way to properly test the ECU/BCM etc. I do not want to fry any of these components :D
Customer: replied 9 months ago.
Should i change the throttle body?? I'm desperate.
Expert:  Jay replied 9 months ago.

Can you give me some history on how this started? did it die on you running? or just wouldn't start one day?

Customer: replied 9 months ago.
Ok.. I hope this doesn't come across the wrong way but you've asked me this twice before, so if you don't mind, i'll copy and paste my last answer to this question. Or maybe i'm misunderstanding .. but basically it just wouldn't start one day. I t had no issues prior... Well no issues that i saw or felt.The car has been maintained as per Nissan recommendations, It is serviced (oil/filters/plugs) every 3 months irrespective of usage/Mileage. In short i spare no expense. The car has been trouble free throughout.One day when i was driving into the parking lot, the car idled heavily (as though it was suffocating due to lack of fuel/air). It did not cut out. I assumed that my air filter was dirty. I parked as normal without any further issues. After work, the car just will not start... This was the beginning of my troubleshooting (change of fuel pump/filters, sensors).The car did not have any performance issues before this apart from a lag (car will take a few seconds actually propel hard when accelerator was floored)
Expert:  Jay replied 9 months ago.

sorry, didn't mean to ask again. Some times has past and I have answered other questions. So I forgot if I asked.

Expert:  Jay replied 9 months ago.

How is the oil level?

Customer: replied 9 months ago.
No problem. lol.Oil level is good. Dead on the maximum mark (cold engine reading)
Expert:  Jay replied 9 months ago.

This may be easier to figure out if I spoke with you.

Would that be something you are interested in?

Customer: replied 9 months ago.
Ok... no problem. This will have to be tomorrow when i can actually go through your suggestions/directions on the car. I'm available all day so let me know what time
Expert:  Jay replied 9 months ago.

What state are you in? Time Zone?

Customer: replied 9 months ago.
4 hrs. It's 10:06 pm here at the moment
Expert:  Jay replied 9 months ago.

It is 9;09 pm here. I just noticed your not in the States.

Customer: replied 9 months ago.
lol.. No. If i was, i'd take it in to the dealership and PAY FOR MY STRESS. ... Literally
Expert:  Jay replied 9 months ago.

not a problem. Lets try around 1pm tomorrow your time. Noon time for me

Customer: replied 9 months ago.
that's great
Expert:  Jay replied 9 months ago.

Talk to you then

Expert:  Jay replied 9 months ago.

Waiting on you.

Customer: replied 8 months ago.
Jay, Please accept my apologies.. i missed the appointment due to an issue beyond my control. How does it work? Do i call you or you call me? What's the earliest can we do this in the morning? (i'm an hour ahead of you)
Expert:  Jay replied 8 months ago.

We can try tomorrow morning if you like. I will be available around 9 am EST which would be 10 am your time.

Let me know if that works for you?

Customer: replied 8 months ago.
I start work at 10 but i'll go in a bit later. i will be available. Need to get this sorted asap.
Expert:  Jay replied 8 months ago.

I would do it earlier but I have to take my daughter to school.

Customer: replied 8 months ago.
Cool No problem. Is there anything i need to have prior to this call? Apart from the ODB scan tool... I don't have that.
Expert:  Jay replied 8 months ago.

It's hard to say. I don't know how long we will be on the phone. I don't know if I am going to have you do checks with me on the phone, or have you do checks and get back to me. I am sure once we talk, we can communicate much clearer about what is going on with out the delay in typing and not properly understanding everything.

Friday morning may be better. Cause I have a appointment at 10 am. Which I would need to leave at 9:30

Would that work better for you?

Customer: replied 8 months ago.
lol... yeah. i will put a reminder. that's fine
Expert:  Jay replied 8 months ago.

Ok then., Friday morning 9 am my time, 10 am your time.. Talk to you then!

Related Infiniti Questions