How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jay Your Own Question
Jay
Jay, Certified Infiniti Technician
Category: Infiniti
Satisfied Customers: 19061
Experience:  20+years, Nissan and Infiniti experience and currently now working for a Infiniti Dealer
10181755
Type Your Infiniti Question Here...
Jay is online now
A new question is answered every 9 seconds

1997 infinity qx4 v6 wasnt getting fuel pressure to the fuel

Customer Question

1997 infinity qx4 v6 wasnt getting fuel pressure to the fuel rail. changed the pump filter ect and now i have fuel to the rail. evry time i get it to start now its will bog out and die any time the accelerator is pressed. smoke normaly comes out of the throttle body after it dies.
Submitted: 12 months ago.
Category: Infiniti
Customer: replied 12 months ago.
also veichle has no check engine lights on and no codes in the system. i have spark. runs decent with no major missfire when running at idle.
Expert:  Jay replied 12 months ago.

Hello my name is ***** ***** thank you for your question.

Will the truck start and idle? Do you have a fuel pressure gauge? Did you change the fuel filter a well as the pump?

Customer: replied 11 months ago.
i have fuel pressure to the fuel rail now i changed the pump and the filter and relay already. it will start and idle now. it only dies when tryng to give it any throttle.
Customer: replied 11 months ago.
it came into my shop not running at all i was only getting about 40 psi of fuel pressure from the pump so i changed the pump and filter. now im getting over 100 psi from the pump.
Expert:  Jay replied 11 months ago.

Wow!! Your year QX4 should only have 36 psi of fuel pressure.. 100 psi is way to much!!! Are you sure you have the correct fuel pump?

Customer: replied 11 months ago.
It was the distributor assembly
Expert:  Jay replied 11 months ago.

Glad you found the problem

Thanks for the update..

Thanks Jay!