How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jay Your Own Question
Jay
Jay, Certified Infiniti Technician
Category: Infiniti
Satisfied Customers: 19500
Experience:  20+years, Nissan and Infiniti experience and currently now working for a Infiniti Dealer
10181755
Type Your Infiniti Question Here...
Jay is online now
A new question is answered every 9 seconds

2001 Xterra. Lost cylinder #2, compression 135lb. fire good

Customer Question

2001 Xterra. Lost cylinder #2, compression 135lb. fire good and plug new. Injector pulse is weak only on that cylinder. At idle takes a few seconds before pulsing. At 1500 RPM is almost goes away, at 1800 it gets bright. at 2000 slows and dims to almost
nothing
Submitted: 1 year ago.
Category: Infiniti
Expert:  Jay replied 1 year ago.

Hello my name is ***** ***** thank you for your question

Do you have any codes? Did you disable the fuel system when you did a compression test?

Customer: replied 1 year ago.
has crank sensor code which I changed and made no effect still has code. and yes pulled fuse on injectors to do compression
Expert:  Jay replied 1 year ago.

When I see a crank sensor code, this is most commonly cause by a Cam Sensor actually which is part of the distributor. The Crank sens or signal is caused by the CAM sensor being in the wrong position. So I think you are dealing with a distributor issue. The distributor is fairly common on these trucks as they get older.

Expert:  Jay replied 1 year ago.

If you have any more questions on this, please feel free to ask.

If not, and you're satisfied with my help, please Rate me. That is how I get credit for my work.

I hope I have provided you with Excellent Service.

Thanks Jay!

Customer: replied 1 year ago.
brand new distributor also
Expert:  Jay replied 1 year ago.

Is the distributor After Market? Do you have the original Crank Sensor still?

Expert:  Jay replied 1 year ago.

How many miles do you have on the truck and what brand spark plugs do you have installed?

Expert:  Jay replied 1 year ago.

Hello?

Customer: replied 1 year ago.
178250 miles and NGK
Expert:  Jay replied 1 year ago.

well the compression limit is 128, so you still have good compression. I do know that when it comes to after market electrical parts, they never work right so that could be part of your problem.

Customer: replied 1 year ago.
dist off a running xterra, same problem
Expert:  Jay replied 1 year ago.

Are you sure you put it in correct?

Customer: replied 1 year ago.
put that one back in the running one and its fine
Expert:  Jay replied 1 year ago.

You have no codes?

Customer: replied 1 year ago.
same crank sensor code. but its new
Expert:  Jay replied 1 year ago.

P0335?

Customer: replied 1 year ago.
let me check to make sure
Expert:  Jay replied 1 year ago.

ok..

Was a engine or trans done on the truck or something?

Customer: replied 1 year ago.
transmission but was doing this before
Expert:  Jay replied 1 year ago.

I can tell you right now, I had a tendency of doing this and remove the transmission and forget about the crank sensor and damage the harness. Can you just check the harness and the connector for the crank sensor to make sure there is no damage? Also, how long ago was the trans replaced and it ran after it was done?

Customer: replied 1 year ago.
it was running bad then transmission went out. I replaced transmission and started working on miss firing problem. the compression was good on the cylinder thats why I went ahead and installed the transmission, also a friend gave it to me.
Expert:  Jay replied 1 year ago.

You may want to check the fly wheel for damage. Thatnos what the cranks sensor reads

Customer: replied 1 year ago.
I know, I did check. And that would not explain why sometimes it runs perfect
Expert:  Jay replied 1 year ago.

What is the exact code number you are getting as of right now?

Related Infiniti Questions