How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jay Your Own Question
Jay
Jay, Certified Infiniti Technician
Category: Infiniti
Satisfied Customers: 18713
Experience:  20+years, Nissan and Infiniti experience and currently now working for a Infiniti Dealer
10181755
Type Your Infiniti Question Here...
Jay is online now
A new question is answered every 9 seconds

Infiniti g35s: What if its cranking but not starting

Customer Question

What if its cranking but not starting
Submitted: 1 year ago.
Category: Infiniti
Expert:  Jay replied 1 year ago.
Hi, My name is***** happy to help you. During our conversation, I may be presenting you with different things to try, and ask you some Questions to get a better understand of the issue so I can answer your question properly. So stick with me to the end, and I am sure we should be able to get this issue resolved for you!
Did you have a Service Engine Soon light on when it was last running? Also, did you get gas recently?
Let me know
Customer: replied 1 year ago.
Hi, just a bit if background info I'm a used car dealer and I bought the car inop status from insurance auction and actually just put another motor in it out of a car I drove for over a year, then I heard knocking sounds when my mechanic crunk it up and then it was smoking then I the transmission went out so I pushed it back in garage now it want crank it seems like its not getting any gas. So the engine and trans comes from my previous 2007 infiniti g35 with 102k miles no prombles at all. The only code the new car had was a p010c something about MAF sensor
Expert:  Jay replied 1 year ago.
Try unplugging both MAF sensors, and see if the car will start and idle.
Customer: replied 1 year ago.
Ok will try in morning when i open lot
Expert:  Jay replied 1 year ago.
ok
Customer: replied 1 year ago.
(Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 1 year ago.
I chose the call me option...I unplugged both MAF sensors same result..
Expert:  Jay replied 1 year ago.
I offered you additional service so if you would like to speak to me about this we can speak on the phone
Customer: replied 1 year ago.
Ok I don't have my card info in hand so I will stick with this forum. I just checked codes and now I'm getting P0335 and p0113 however the MAFS are still unplugged I think that may have some to do with the p0113 code.. I loosened the fuel damper and no gas squirted out.
Expert:  Jay replied 1 year ago.
I will be back online in about 45 mins
You have a crank sensor code which could be causing your issue
Expert:  Jay replied 1 year ago.
OK.. This crank sensor code. Did you inspect the crank sensor where it mounts on the transmission bell housing area? Is this a Auto Trans or Manual?
Customer: replied 1 year ago.
yes it was loose it seems like the wrong bolt was put in does the bolt suppose to have two washers to your knowledge? and will a crank sensor stop it from getting gas?
Expert:  Jay replied 1 year ago.
There is no washers for the crank sensor. It's only a 10 mm bolt. You want to make sure nothing hit the sensor also if it was loose. You may want to get the correct 10 mm bolt, so it doesn't come loose again. With out that signal, the computer doesn't see the engine turning over and will not produce spark or injector pulse. Is this car a auto trans or a manual trans?
Customer: replied 1 year ago.
AUTO
Expert:  Jay replied 1 year ago.
Ok.. just wanted to be sure. Cause if it was a stick, if the flywheel was bolted in the wrong location, you can get that as well. Did you try to secure the crank sensor and see if it would start? Plug in the MAF sensors of course now that you have found that.. Let me know..
Customer: replied 1 year ago.
Ok you said the bolt shouldn't need washers so I'm going to get a shorter bolt because obviously the mechanic put wrong one in and I will update you then thanks.
Expert:  Jay replied 1 year ago.
Ok, .. Let me know..