How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike V. Your Own Question
Mike V.
Mike V., Infiniti Mechanic
Category: Infiniti
Satisfied Customers: 23839
Experience:  Factory trained to repair Nissan and Subaru.
2921078
Type Your Infiniti Question Here...
Mike V. is online now
A new question is answered every 9 seconds

my infiniti 99 I30 will crank but wont start. I just changed

This answer was rated:

my infiniti 99 I30 will crank but wont start. I just changed the starter and the MAF. Security light is on solid.
Chat Conversation Started
Carguy1 :

HI there! If the security light is on solid while cranking the immobilizer has turned the fuel injectors off. Do you have a second key by chance?

JACUSTOMER-0objqwl8- :

I do but it is with my mother

JACUSTOMER-0objqwl8- :

will it start with another key?

JACUSTOMER-0objqwl8- :

she has the fob as well

JACUSTOMER-0objqwl8- :

will that help?

Carguy1 :

You might be able to get the car out of lockout with the new or different key. Here are instructions to try it.

Carguy1 :

The key fob doesn't matter, one second whiule I get the instructions

Carguy1 :

Full Size Image

Carguy1 :

Do the section that is circled. If the light doesn't go out you are going to have to have the dealer reprogram all the keys.

JACUSTOMER-0objqwl8- :

will this work with the key I have?

Carguy1 :

I suspect your key is causing the problem. You can try it, but only try it once. If it doesn't work,then use the known good key. If you try to many times it won't work.

JACUSTOMER-0objqwl8- :

this key is her usual key though

Carguy1 :

Ok, well what I am saying is that it is better to try a spare key then the one that you have been using

JACUSTOMER-0objqwl8- :

ok...thanks

Carguy1 :

If this is what you have, try it once, it may work. Trying to keep you out of the dealership is all :)

Customer: replied 6 years ago.

well...when I put the new key in the security light is not on anymore but it still wont fire

 

Ok, so now the light is going out when you try to start it?
Customer: replied 6 years ago.

yes

 

Ok, try spraying some carb cleaner into the throttle and see if it will fire on it for a few seconds and let me know!
Customer: replied 6 years ago.

the check engine light is on too....

 

 

That is normal, it should come on when you turn the key on.
Customer: replied 6 years ago.

i dont have any carb cleaner but will go get some.

 

Do I need to disconnect anything to spray into the throttle?

 

Yes, the tube from the air filter box going to the throttle. Just loosen the clamp and slide the hose off, then open the throttle and spray some in there. Slip the hose back over it. Don't have to tighten the clamp for testing. Let me know what you find. Starting fluid will work also if you have that.
Customer: replied 6 years ago.
that didnt work either. guess I am taking it to the shop unless you some other idea
So it didn't try to fire at all on the carb cleaner? I don't expect it to run really, just pop off a couple of times.
Customer: replied 6 years ago.
nothing....
So, the light is no longer on, does it flash when the key is out of the ignition? The security light I mean?
Customer: replied 6 years ago.
light is flashing before inserting the key...and is off when trying to start
IT sounds like the security is back to normal but the car has no spark.
The only other suggestion I have is to get a code reader and see if there is a code stored for The cam or crank sensor.
Customer: replied 6 years ago.
i tried getting the code without a sensor (manually using a small screwdriver and counting the check engine light flashes) and if I counted right it said 0802 which I found on the internet means something about the crank sensor
Customer: replied 6 years ago.
actually...just bought a code reader and it pulled P0335 - CKP sensor (pos)...would that be the cause? If so, how do I change it?
Yes, the crank sensor can be the problem. Just strange that we went from a security issue to the crank sensor.
It is located just below the starter on the bell housing. Here is a diagram of it.Make sure to check the harness in that area first. You might have pinched it or something when the starter went in.
graphic
Customer: replied 6 years ago.
do I have to access this from under the car?
It is easier to get to from under the car. The engine mount is right in that area and makes it hard to see and get to. Also for replacement. Really pretty easy to do,one bolt and the harness and it is out. The new one just pops back in.
Customer: replied 6 years ago.
the battery was a little sluggish when I tried to start it today...would that make the sensor read this way? the code reader said it was a pending code
The engine needs a minimum of 250 rpms to fire,so it is possible. It is also possible that it isn't the battery causing the problem if you put in an aftermarket starter. I have seen several of these cause problems.
Customer: replied 6 years ago.
i am having a hard time finding it. can you give me some more specific location directions? I am looking down from the top. I removed the air intake/filter etc housings.
It is in between the radiator and the engine on the bell housing, about midway down.
Here is a diagram of the sensor harness location. See if you can follow it to the sensor. Just aren't any good diagrams of the thing.
graphic
graphic
Customer: replied 6 years ago.
got it out it has little metal shards on it is that normal?
It may have tiny little shards on it. Without seeing it is hard to say, it will mess up the sensors ability to read. Clean them off and see if there is improvement. Might be off of the starter. Was the starter replaced to resolve a crank and no fire issue?
Customer: replied 6 years ago.
do i need to clean it with sensor cleaner or any special substance? replaced the starter because when the key was turned, it would pause before the starter would engage. this is my moms car and they told her it needed a new starter :)
I would wipe it off with a rag and try it. It is a magnet as you can tell, and the flywheel makes the magnet make a signal. If it works, great, if not, replace it with new. You should be able to get one at the Zone :)
Customer: replied 6 years ago.
thanks man. hopefully this is it. and I promise I am not trying to short change you, i just want to make sure you get paid. I have never used this site before so I keep holding off on hitting accept answer in fear of losing our conversation. I promise I will pay you what was suggestged plus a little more. I am going to try this stuff tonight and I will let you know in the morning if it works or I destroy the whole car in a fit of rage.
No problem at all! Hope it works!
Mike V. and 3 other Infiniti Specialists are ready to help you
Customer: replied 6 years ago.
didnt work. calling a AAA today to tow to shop.
Thanks for the accept and bonus! Sorry we couldn't get it going, probably find a broken wire someplace. It started out as a security issue so I am not sure what happened her. Would love to know what is found if you don't mind doing some follow up with me.
Mike
Customer: replied 6 years ago.
two fuses were blown. ECM A and ECM B. only 88 bucks to fix. But it took the shop all day to trace that down, they were getting the same code reading as I was

thanks for all your help
Jeff
wow, I really appreciate the follow up. Can't imagine how long it would have take us to get that over the web!
I really appreciate the accept and bonus.
Mike