How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jeff Policky Your Own Question
Jeff Policky
Jeff Policky, Motorcycle Mechanic
Category: Motorcycle
Satisfied Customers: 2425
Experience:  Yamaha Gold, Suzuki Gold, Honda Bronze, Polaris Bronze, BRP
17258690
Type Your Motorcycle Question Here...
Jeff Policky is online now
A new question is answered every 9 seconds

I have a 620 mule with a non-starting problem. Turn on

Customer Question

Hi Doug,
I have a 620 mule with a non-starting problem.
Turn on ignition, fuel pump pulses fine, but no spark at either plug.
Any ideas?
Submitted: 1 month ago.
Category: Motorcycle
Expert:  Kenny O. replied 1 month ago.

Hi this is Kenny, not sure how much Doug in on here, I can help you if you like.

If so I need the year/model code, I could normally pull it from the VIN number if you have that, also do you have access to a multi-meter ?

Thanks

Kenny

Customer: replied 1 month ago.
Hi Kenny,
It's a 2001 KAF620 A6, don't have the vin as I'm not with the mule at the moment.
There is 12 volts to the coils and the fuel pump pulses with the ignition on. I've been through all the wiring and there were a few dirty looking connections at the connectors so cleaned everything up.
I suspect it may be the CDI unit as it would be odd for both plugs to have no spark, I'm thinking....
Meter at the ready....

Related Motorcycle Questions