How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve
Steve, Motorcycle Mechanic
Category: Motorcycle
Satisfied Customers: 6828
Experience:  30+ yrs. experience, MMI, HD technician, HD early, engine rebuild/performance, bike builder, kit bike program manager, CCI 2001-2004
11090168
Type Your Motorcycle Question Here...
Steve is online now
A new question is answered every 9 seconds

2001 roadking efi- won't start- new battery, start button

Customer Question

2001 roadking efi- won't start- new battery, start button does nothing - starter makes no noise
JA: Have you checked the battery, particularly the terminal connections? Are they corroded?
Customer: All fuses good, replaced all 3 relays also. Code of 31 & 34 was present when I ran thru flash routine
JA: What is the model of your '01 motorcycle?
Customer: Roadking FLHRI
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: replaced battery (charged it as well, checked all fuses - replaced start, brake, & under seat relays with brand new HD parts
JA: Anything else you think the mechanic should know?
Customer: Starter worked fine before dead battery- now hitting start button acts like I never pressed it- no noise
Submitted: 3 months ago.
Category: Motorcycle
Expert:  Steve replied 3 months ago.

Hi. My name is ***** ***** I would appreciate the opportunity to help with your question.

Expert:  Steve replied 3 months ago.

31 - alarm output low

34 - loss of idle speed control.

these are unrelated and may have another cause.

we should start by checking the battery.

measure the battery under the following conditions:

- ignition OFF.

- ignition ON.

- with the start button depressed.

let me know what you find.

Steve

Customer: replied 3 months ago.
This is to Steve - in response to your information & battery tests: Ignition - OFF- 12.55 V, with Ignition- ON- 12.3 V, pressing start button- 12.3 V (same as with ignition ON)
Expert:  Steve replied 3 months ago.

your symptoms indicate you may have a armed HD security system on your bike.

if that is the case, replace the battery in the security FOB and try again.

let me now if you need more help.

Steve

Customer: replied 3 months ago.
Starter engages when jumping green wire on solenoid to starter main hot post. I get nothing when hitting start button. Some security bypass? I have working button key fob but seems like security goes off?Year: 2001
Model: FLHRI
Engine: Big twin 88 EFI
Expert:  Steve replied 3 months ago.

once more.........

your symptoms indicate you may have a armed HD security system on your bike.

if that is the case, replace the battery in the security FOB and try again.

let me now if you need more help.

Steve

Customer: replied 2 months ago.
Thanks so much so far Steve - I really do appreciate your wisdom. My problem is still that I can't get any response from start button after changing dead (bije) battery - everything worked perfect b4 battery change. Starter moves when jumping green wire & I know battery &fuses & relays are good. I can set&reset alarm with key fob - been but it acts like alarm is still set when turning on ignition. Lights blink & will come back on when I hit double click on fob? If I use key fob to set alarm & then reset- it acts ok because I see red key blink (active) & then go off when I double click fob. On ignition switch to ON, flashing lights? Again- everything worked great b4 battery died. How do I reset TSSM or other security issue I might have ?-that doesn't seem to reset when I use my button key fob? I really am desperate- If it matters I am very electrically knowledgeable (degreed & experienced for 25 years on industrial automation systems) - but obviously an idiot on motorcycles for sure. That's why I need your expertise & experience- & I really appreciate your knowledge. I don't expect to learn your 30+ years of expertise (or naive or disrespectful enough to remotely imply that). Anything you can help me with - is very sincerely appreciated.
Expert:  Steve replied 2 months ago.

why did you replace the battery? how long was the bike dead?

Expert:  Steve replied 2 months ago.

let me know if you need more help.

if not, please leave a POSITIVE RATING.

thank you,

Steve

Customer: replied 2 months ago.
No problem on rating Steve - I appreciate you trying to help me thru this. The battery (which was installed just last August 2015) died sometime after January 2016 & I didn't know (or expect it to be dead, dead, dead & unchargeable after 5-6 months). That battery wouldn't light up anything or respond to charge or jump. Everything ran perfect until that super dead battery. So, I got another brand new battery (this Spring) & replaced it like I've done before, & turned ignition on - got headlights & hear EFI fuel pump prime- so I was expecting to start & be good to go. Never had a battery completely die so bad - but sure thought putting a new battery in would be a quick job as usual. But starter is disabled- maybe I need to reset TSSM or something? My button key fob works & I can set/reset security with it - but that doesn't seem to enable starter. Starter works when jumping, battery is new & fully charged & tested. All fuses good, relays new & good (but I did not install new EFI black relay on right side next to fuel pump relay). So I can't say that relay is good but don't have a reason to suspect that unless it locks out starter. Guessing dead battery triggered theft lockout? If there is such a thing. Button key fob works/ resets normal alarm - but starter locked out some how? Do I need to do a ECU TSSM system reset (the (3) ten minute procedure or what?). Youre suggestions/ advice would be greatly appreciated.
Expert:  Steve replied 2 months ago.

Glad I could help.

as I said, your security system WAS armed. I apologize for not being able to see the broken antenna from here, but I am working on that.

unfortunately, I rely on YOUR input to help you fix your bike and do not have the luxury of all of my faculties.

let me know if you have other questions.

Steve

Customer: replied 2 months ago.
I don't have an antenna but maybe I am missing a joke. I also believe there probably is an alarm function which has my starter locked out. Alarm sets/resets with my button fob but does not let start button work. Isn't there a procedure to reset TSSM or whatever since everything worked perfect b4 the bike battery died? I have working fob & know my PIN- Need rest of security off so starter can engage
Expert:  Steve replied 2 months ago.

sorry, I got your question confused with someone else.

your bike does, indeed, believe it was stolen and your security system is locked up. it's not a relay, it's done through the software.

you need to perform the password ***** routine.

make sure the bike is connected to a battery charger.

you can find it on the internet if you search " HD password *****".

if you mess up a step, start over.

if you miss a step....start over.

if it doesn't work the first time......start over.

just be patient. it's going to take a while but should revolve your problem.

Steve

Expert:  Steve replied 2 months ago.

let me know if you need more help.

if not, please leave a POSITIVE RATING.

thank you,

Steve

Expert:  Steve replied 1 month ago.

let me know if you need more help.

if not, please leave a POSITIVE RATING.

thank you,

Steve