How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve, Motorcycle Mechanic
Category: Motorcycle
Satisfied Customers: 6816
Experience:  30+ yrs. experience, MMI, HD technician, HD early, engine rebuild/performance, bike builder, kit bike program manager, CCI 2001-2004
Type Your Motorcycle Question Here...
Steve is online now
A new question is answered every 9 seconds

Rode my 07 ultra classic electra glide 350 miles on new

Customer Question

rode my 07 ultra classic electra glide 350 miles on new spark plugs. ran great! parked it for a week while I went to work out of state. just got back and went to go for a ride and my fuel pump does not come on and the bike wont start. it does have a thunder max ecm on it that was installed before I bought the bike.?????? what the ......? it has been running great. why would the fuel pump just all of a sudden stop working? I normally get the amber engine light while the pump is "charging." and then I start the bike. I get no amber engine light right now and I do not hear my fuel pump. what the f....?
Submitted: 2 months ago.
Category: Motorcycle
Expert:  Steve replied 2 months ago.

check the fuel system and ECM fuses.

verify the fuel and ECM relays are picking up when the ignition is turned on.

let me know if you need more help.


Customer: replied 2 months ago.
steve my friend, thank you! now, can you tell me where I will find the fuses and the relays? and how do I test the relays? ohm meter? sorry for the stupid questions, but this is my first newer bike. up until now ive been riding an 83 shovel and an 85 electra glide. really appreciate your time. Tom
Expert:  Steve replied 2 months ago.

the fuel injection components are located behind the right side cover.

the ECM fuse is the 5A fuse, the Fuel system fuse is the 15A fuse.

the relays should "pull in" with an audible click when the ignition is turned on, for about 4 seconds, then they turn off until you hit the start button..

check relay operation by checking for output voltage when they pull in.

the fuel system relay output is the yellow/green wire to the fuel pump connector (under the seat), fuel injectors and the coil.


Expert:  Steve replied 1 month ago.

let me know if you need more help.

if not, please leave a POSITIVE RATING.

thank you,