How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Louie Your Own Question
Louie
Louie, Technician
Category: Motorcycle
Satisfied Customers: 11612
Experience:  25+ yrs. experience
13948492
Type Your Motorcycle Question Here...
Louie is online now
A new question is answered every 9 seconds

I have a 2008 kawasaki 3010 mule that was running fine when

Customer Question

I have a 2008 kawasaki 3010 mule that was running fine when I parked it to go on vacation, now it will not respond at all, as if battery is not there, battery reads 12.75 volts all fuses good and bike is in neutral
JA: Have you checked all the fuses? Do you have a wiring diagram?
Customer: checked all fuses that are in fuse box, no, I do not have a wiring diagram, are there any hidden fuses? and where is the neutral sw.?
JA: Are you fixing your bike yourself? What have you tried so far? What confuses you?
Customer: yes, I am fixing myself, tried all fuses and checked battery, not really confused just can't find problem
JA: Anything else you want the mechanic to know before I connect you?
Customer: nothing I can think of
Submitted: 5 months ago.
Category: Motorcycle
Expert:  Louie replied 5 months ago.

Hi and welcome to JustAnswer,

Thank you for the question and your patience. Should you still need assistance for information purposes only...

Initially, re-inspect the battery, its ground lines and/or check/clean the battery cables + terminals, connectors and wiring as a preliminary consideration. Have the battery externally charged and then LOAD TESTed (even if new/charged and just for the purpose of eliminating it as a suspect).

Proposed secondary tries (if have not been done):

  • • check/clean all the black/yellow wires connectors and terminals including those to engine and frame ground as well as the - battery terminal 's black wire;
  • • test for +12V on the white, red and white/red wires from the battery's + terminal.
Customer: replied 5 months ago.
battery voltage is 12.75 volts, I have cleaned the terminals
Expert:  Louie replied 5 months ago.

As posted above:

  • load test the battery;
  • check all the black/yellow wires;
  • test for +12V on white, red and white/red wires.

Please post back results / observations of the above once done.