How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Louie Your Own Question
Louie, Technician
Category: Motorcycle
Satisfied Customers: 11243
Experience:  25+ yrs. experience
Type Your Motorcycle Question Here...
Louie is online now
A new question is answered every 9 seconds

2002 st2 no lights/inst panel/ no pump nothing. Pull 30 amp

Customer Question

2002 st2 no lights/inst panel/ no pump nothing. Pull 30 amp fuse and reinstall inst panel light comes on for a few seconds. Have cheched all fuses and cleaned large connector on left that gets wet and corroaded. Has worked before but not this time. Need help please,thanks rodney gross***@******.***
Submitted: 2 months ago.
Category: Motorcycle
Customer: replied 2 months ago.
Expert:  Louie replied 2 months ago.

Hi Rodney and welcome to JustAnswer,

Thank you for the question and your patience. Should you still need assistance for information purposes only...

Initially, proposed preliminary checks (if have not been done) is to re-inspect the battery, its ground lines and/or check/clean the battery cables + terminals, connectors and wiring as a preliminary consideration. Have the battery externally charged and then LOAD TESTed (even if new/charged and just for the purpose of eliminating it as a suspect).

Customer: replied 2 months ago.
Battery is good,all connections are fine. I am a mechanic and looking for all help . I have checked wiring and have found nothing.
Expert:  Louie replied 2 months ago.

Let's work on the basics 1 at a time; (1) ensure good ground path. For test purposes, temporarily hardwire a secondary ground wire from the battery's - terminal to the frame, then also to the engine and then to several black wires of the harness including the headlight's.

With ensured good ground, test for the presence and consistency of +12V on ALL red wires and white wires.

Customer: replied 2 months ago.
You dont seen to understand that i have power to fuse panel,grounds are fine . You must not work on ducatis much. This seens like a waste of my time and money.
Expert:  Louie replied 2 months ago.

There is a 24-pin connector that may be suspect and the above proposed test would help determine the likely culprit.

Perhaps an alternate approach to your concern would be to your preference.

The question would be re-opened as I would rather opt out.

Still, good luck with the ST2

Customer: replied 2 months ago.
The connector was where i went first as water gets in that all the time. When you plug it back in it too will light up inst panel for a few seconds . Thats where im at now thanks