How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Louie Your Own Question
Louie
Louie, Technician
Category: Motorcycle
Satisfied Customers: 11948
Experience:  25+ yrs. experience
13948492
Type Your Motorcycle Question Here...
Louie is online now
A new question is answered every 9 seconds

Have a 2010 mule Trans 4x4: idles fine but loses power when

Customer Question

have a 2010 mule Trans 4x4: idles fine but loses power when i depress gas pedal and goes very slow, when i back off of power it runs a bit better but no power.
Chris
Submitted: 9 months ago.
Category: Motorcycle
Expert:  Louie replied 9 months ago.

Hi Chris and welcome to JustAnswer,

Thank you for the question and your patience. Should you still need assistance for information purposes only...

Initially, not sure if the 2010 is year or model. ...gas or diesel?

Still, it would appear to be a fuel delivery/starvation issue (most likely) or electrical/ignition (least likely particularly for the gas version). Proposed preliminary tries (if have not been done):

  • • re-clean the fuel path, drain the tank and replace again with fresh fuel;
  • • check the air box and air filter/element;
  • - ensure tight/correct fit;
  • • verify fuel is reaching the combustion chamber;
  • • check the battery voltage when revving for potential over charging;
  • - if overly high, try/run with the regulator temporarily disconnected.