How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete, Technician
Category: Motorcycle
Satisfied Customers: 24184
Experience:  17 years automotive training and experience.
Type Your Motorcycle Question Here...
Pete is online now
A new question is answered every 9 seconds

I have a 2013 xp900,when I start it the idle is going up and

Customer Question

I have a 2013 xp900,when I start it the idle is going up and down,and it is throwing a code,changed the vein sensor did not help,,what should I do ,is there a reset?
Submitted: 3 months ago.
Category: Motorcycle
Expert:  Pete replied 3 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

Depending on the code set here one common issue can be a fault with a vacuum leak on the engine needing repaired.I have seen vacuum leaks cause this type of fault here before in the past needing repaired.If you have not checked for vacuum leaks this needs done.If this was already checked into or is not the issue here let me know.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Related Motorcycle Questions