How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jeff Policky Your Own Question
Jeff Policky
Jeff Policky, Motorcycle Mechanic
Category: Motorcycle
Satisfied Customers: 2425
Experience:  Yamaha Gold, Suzuki Gold, Honda Bronze, Polaris Bronze, BRP
17258690
Type Your Motorcycle Question Here...
Jeff Policky is online now
A new question is answered every 9 seconds

I have a 2007 Harley Dyna Low Rider, completely stock except

Customer Question

I have a 2007 Harley Dyna Low Rider, completely stock except for Vance and Hines pipes and a Power Commander that was installed three years ago. The bike has always run like a top for 65,000 miles without major repair. Over the last 6 months or so I am having starting problems (cranking but not starting) which began when the engine was hot. Cold starts were not a problem, now they are. This has progressed to dangerous stalling at all speeds. The engine completely cuts out, no sputtering or loss of power, it just dies. I go thru the drills of ignition off, start/stop off, wait, retry and can always get it restarted but with difficulty. When it is running it runs strong - no loss of power, no indication that something is about to go wrong. I replaced the plugs and the voltage regulator with no improvement. There are no trouble codes, all indicators and gages work fine. What do you think? Thank you.
Submitted: 5 months ago.
Category: Motorcycle
Expert:  kwiggins29059 replied 5 months ago.

Hello, the first step in diagnosing this is going to be removing the power commander. Many times I've seen them go out and effect starting. Let me know how it goes and we can work further if needed.

Customer: replied 5 months ago.
I can easily disconnect the Power Commander but the O2 sensor ports are plugged. Will the bike even start and run with no O2 sensors installed?
Expert:  kwiggins29059 replied 5 months ago.

Yes, it will star t and run without the O2's. The check engine light will likely come on and it may urn a little rich.

Customer: replied 5 months ago.
Ok, first thing tomorrow I will disconnect the Power Commander and try it out.1. If it starts and runs good is there danger of damaging other components by riding for a day or two until the new Power Commander arrives.2. Suppose it's not the Power Commander and I have the same problems. What should I do next?Thank you.
Expert:  kwiggins29059 replied 5 months ago.

1. I would not ride it without working O2 sensors

2. If it's not the power commander we will need to look into the crank position sensor, ignition module and associated wiring.

I'll be around tommorrow, let me know how things go