How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Motorcycle
Satisfied Customers: 27065
Experience:  17 years automotive training and experience.
14928985
Type Your Motorcycle Question Here...
Pete is online now
A new question is answered every 9 seconds

2014 victory ghball. I installed a s&s air intake with

Customer Question

2014 victory highball. I installed a s&s air intake with hacker zoomies and a power commander v with auto tune. Went to start the bike and the fuel pump starts priming and doesn't stop, I have no power to my gages or brake lights but have power to my headlight. Fuses were good, all connectors were connected and battery hooked up. What could i be missing, hooked all connectors back with out the pcv and auto tune and symptom.
Submitted: 11 months ago.
Category: Motorcycle
Customer: replied 11 months ago.
I have a 2014 victory highball. I installed a s&s air intake with hacker zoomies and a power commander v with auto tune. Went to start the bike and the fuel pump starts priming and doesn't stop, I have no power to my gages or brake lights but have power to my headlight. Fuses were good, all connectors were connected and battery hooked up. What could I be missing, hooked all connectors back with out the pcv and auto tune and symptom didn’t change. Do you have any idea what could be causing this.
Expert:  Pete replied 11 months ago.

Hi,my name is ***** ***** I will be happy to try to assist you with this.I may need more information in some cases to help with answering your question.

Expert:  Pete replied 11 months ago.

My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

Make sure nothing was damaged or disconnected when this repair was done as this can cause an issue like this here in some cases especially a loose or damaged ground cable.If this is or has been checked already and found to be o.k. let me know so we can continue from here.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 11 months ago.
Thank you for your advise. but we went over everything prior to me posting. So I was looking for a little more info like this cable or fuse controls the computer system.
Expert:  Pete replied 11 months ago.

Your welcome.

Unfortunately this is all of the info I have on this here myself but others here may be able to assist further.

I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.

Thanks Pete